
Помогите, пожалуйста! 1. Написать программу которая ищет n! (цикл while)2. Написать программу,
которая находит число Р = (1-1/2)(1-1/3)*...*(1-1/n). N вводится с клавиатуры. (цикл for)

Ответы на вопрос

Ответ:
Объяснение:
1.
var
k:integer;
p:integer;
n:integer;
begin
readln(n);
p:=1;
k:=1;
while (k <= n) do begin
p:=p*k;
k:=k+1;
end;
writeln(p);
end.
2.
var
k:integer;
p:real;
n:integer;
begin
readln(n);
p:=1;
for k:=2 to n do begin
p:=p*(1 - (1/k));
end;
writeln(p);
end.



Программа для вычисления факториала n с использованием цикла while
```cpp
#include
int main() { int n; cout << "Введите число n: "; cin >> n;
int factorial = 1; int i = 1;
while (i <= n) { factorial *= i; i++; }
cout << "Факториал числа " << n << " равен " << factorial << endl;
return 0; } ```
Объяснение кода: - Программа запрашивает у пользователя число `n`. - Затем инициализируется переменная `factorial` со значением 1 и переменная `i` со значением 1. - В цикле `while` происходит умножение переменной `factorial` на `i`, а затем `i` увеличивается на 1. - Цикл выполняется до тех пор, пока `i` не станет больше `n`. - После завершения цикла, программа выводит результат - факториал числа `n`.
Программа для вычисления числа P = (1-1/2)(1-1/3)*...*(1-1/n) с использованием цикла for
```cpp
#include
int main() { int n; cout << "Введите число n: "; cin >> n;
double P = 1.0;
for (int i = 2; i <= n; i++) { P *= (1 - 1.0 / i); }
cout << "Значение числа P для n = " << n << " равно " << P << endl;
return 0; } ```
Объяснение кода: - Программа запрашивает у пользователя число `n`. - Затем инициализируется переменная `P` со значением 1.0. - В цикле `for` происходит умножение переменной `P` на `(1 - 1.0 / i)` для каждого значения `i` от 2 до `n`. - После завершения цикла, программа выводит результат - значение числа `P` для заданного `n`.
Надеюсь, эти программы помогут вам! Если у вас возникнут еще вопросы, не стесняйтесь задавать.


Похожие вопросы







Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili