Составьте программу для Pascal ABC: В пачке сигарет (20 штук) содержится примерно 3,6 граммов
смолы, которая осаждается в лёгких курильщика. Сколько смолы осядет в легких курильщика за год, если он выкуривает по x сигарет в день?Ответы на вопрос
Программа на паскале:
var x: integer; s: real;
begin
readln(x);
s:=3.6/20*x*365;
writeln(s:4:1, ' гр');
end.
Пример:
5
328.5 гр
Задачу можно решить с помощью следующего алгоритма:
1. Пользователь вводит количество сигарет, которые он выкуривает в день (переменная "x"). 2. Рассчитываем количество сигарет, которые курильщик выкурит за год, умножив "x" на 365 (количество дней в году). Результат сохраняем в переменную "total_cigarettes". 3. Рассчитываем количество граммов смолы, которое содержится в одной пачке сигарет (20 штук). Для этого умножаем 3,6 граммов на количество пачек, которые будет выкуривать курильщик за год. Количество пачек равно "total_cigarettes" / 20. Результат сохраняем в переменную "total_tar". 4. Выводим результат: "Количество граммов смолы, которая осадится в лёгких за год: total_tar".
Вот готовая программа на языке Pascal:
``` program CalculateTar; var x, total_cigarettes, total_tar: integer; begin writeln('Введите количество сигарет, которые вы выкуриваете в день:'); readln(x); total_cigarettes := x * 365; total_tar := 3.6 * (total_cigarettes / 20); writeln('Количество граммов смолы, которая осадится в лёгких за год: ', total_tar); end. ```
Пользователь сначала должен ввести количество сигарет, которые он выкуривает в день. После этого программа рассчитывает и выводит количество граммов смолы, которая осадится в его лёгких за год, исходя из этого значения.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
