PASCAL ABC. Найти значение любого выражения из двух слагаемых!!! т.е. просто чтоб посчитало,
например: 2+2=4, 9/3=3, 7*7=49, 15-5=10Ответы на вопрос
x,y,v:real;
b:string;
begin
writeln('Vvedite znak virajeniya (+, -, *, /)');
readln(b);
writeln('Vvedite pervoe chislo');
readln(x);
writeln('Vvedite vtoroe chislo');
readln(y);
if b = '+' then v:=x+y;
if b = '-' then v:=x-y;
if b = '*' then v:=x*y;
if b = '/' then v:=x/y;
writeln(x, ' ', b, ' ', y, ' = ', v);
end.
begin
writeln('Введите выражение:');
readln(s);
s1:=''; i:=1;
while not (s[i] in ['+','-','*','/']) do
begin
s1:=s1+s[i]; i:=i+1;
end;
val(s1,a,code);
z:=s[i];
s1:=''; i:=i+1;
while s[i] <> '=' do
begin
s1:=s1+s[i]; i:=i+1;
end;
val(s1,b,code);
case z of
'+' : writeln(s,a+b);
'-' : writeln(s,a-b);
'*' : writeln(s,a*b);
'/' : writeln(s,a/b);
end;
end.
Пример:
Введите выражение:
15-5=
15-5=10
Для того чтобы написать программу на Pascal ABC, которая будет вычислять значение любого выражения из двух слагаемых, вам понадобится использовать операторы ввода и вывода, арифметические операторы и переменные.
Вот пример программы, которая выполняет описанную задачу:
```pascal program CalculateExpression;
var a, b, result: integer;
begin // Введите значения для a и b write('Введите значение a: '); readln(a); write('Введите значение b: '); readln(b);
// Вычислите сумму a и b и сохраните результат в переменную result result := a + b;
// Выведите результат writeln('Результат: ', result); end. ```
В этой программе мы используем две переменные `a` и `b`, чтобы хранить значения слагаемых. Затем мы используем оператор `readln` для ввода значений с клавиатуры. Далее мы используем оператор `writeln` для вывода результата на экран.
Давайте рассмотрим пример использования этой программы. Если вы введете значение `a` равное 2 и значение `b` равное 2, программа выведет результат `4`, так как 2 + 2 = 4. Аналогично, если вы введете значение `a` равное 9 и значение `b` равное 3, программа выведет результат `12`, так как 9 + 3 = 12.
Вы можете использовать этот пример программы как основу и изменять арифметические операторы и переменные по вашему усмотрению, чтобы вычислить другие выражения из двух слагаемых.
Примечание: Пожалуйста, учтите, что я предоставил пример программы на основе вашего вопроса, однако Pascal ABC является устаревшим языком программирования, и, возможно, вам будет легче использовать современный язык программирования, такой как Python или Java, для решения подобных задач.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
