Вопрос задан 01.11.2023 в 01:39. Предмет Информатика. Спрашивает Кузнецова Лера.

ДАЮ 55 БАЛЛОВ ЯЗЫК PYTHON, 10 класс: Напишите программу, которая выводит первое слово переданной

её символьной строки. Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки. Входные данные: Входная строка содержит произвольную последовательность символов. Выходные данные: Программа должна вывести первое слово этой строки. Примеры: Входные данные Vasya is a pupil. Выходные данные Vasya Пожалуйста:) а то у меня с python все очень-очень плохо
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Игнатова Валерия.

a = input("Введите строку: ")

for i in range(len(a)):

  if a[i] == ' ' or a[i] == ',' or a[i] == '.' or a[i] == '!' or a[i] == '!' or a[i] == '?' or a[i] == ':':

      break

  else:

      print(a[i],end="")

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на Python, которая будет выводить первое слово из введенной строки. Вот пример такой программы:

```python # Получаем ввод от пользователя input_string = input("Введите строку: ")

# Разбиваем строку на слова, используя пробел как разделитель words = input_string.split()

# Проверяем, что введена хотя бы одна строка if len(words) > 0: # Выводим первое слово first_word = words[0] print("Первое слово: " + first_word) else: print("Введена пустая строка. Попробуйте ещё раз.") ```

Эта программа сначала запрашивает у пользователя ввод строки. Затем она использует метод `split()` для разделения строки на слова, используя пробел как разделитель. Если введена непустая строка, программа выводит первое слово. В противном случае она сообщит, что введена пустая строка.

Пример работы программы: ``` Введите строку: Vasya is a pupil. Первое слово: Vasya ```

Надеюсь, это помогло! Если у вас есть какие-либо дополнительные вопросы или нужна дополнительная помощь, не стесняйтесь спрашивать.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос