
Напишите программу НА ПАСКАЛЕ, которая выводит последнее слово переданной её символьной строки.
Слово – это последовательность непробельных символов, ограниченная пробелами или концами строки. Входные данные Входная строка содержит произвольную последовательность символов. Выходные данные Программа должна вывести последнее слово этой строки. Примеры входные данные Abra babra cadabra выходные данные cadabra

Ответы на вопрос

Program z1; Var i,b,j,n:integer; s,space,h:string; a: array [1..1000] of string;Begin write('Введите текст - '); readln(s); b:=length(s); space:=' '; i:=1; n:=0; j:=1; while i<=b do begin h:=''; while s[i]<>space do begin h:=h+s[i]; i:=i+1; end; a[j]:=h; j:=j+1; i:=i+1; n:=n+1; end; write(a[n],' '); End. Только в конце предложения ставь тоже пробел!
Объяснение:
Сори писал с телефона



Ответ:
Объяснение:
Var
s,s2:string;
i:byte;
begin
readln(s);
for i:=length(s) downto 1 do
if s[i] in [' ','.',','] then delete(s,i,1)
else break;
s2:='';
for i:=length(s) downto 1 do
if not(s[i] in [' ','.',',']) then s2:=s[i]+s2
else break;
writeln(s2);
end.



Программа на Pascal для вывода последнего слова из входной символьной строки может выглядеть следующим образом:
pascalprogram LastWord; var inputString: string; lastWord: string; i, len: integer; begin // Вводим символьную строку writeln('Введите строку:'); readln(inputString); // Инициализируем переменные lastWord := ''; len := length(inputString); // Начинаем обратный проход с конца строки for i := len downto 1 do begin // Если текущий символ не пробел, добавляем его к последнему слову if inputString[i] <> ' ' then lastWord := inputString[i] + lastWord else begin // Если текущий символ пробел и последнее слово уже найдено, завершаем цикл if lastWord <> '' then break; end; end; // Выводим последнее слово writeln('Последнее слово: ', lastWord); end.
Эта программа сначала считывает входную строку, а затем начинает обратный проход по строке, собирая последнее слово. Как только оно найдено, программа завершает выполнение и выводит его на экран.


Похожие вопросы







Топ вопросов за вчера в категории Информатика







Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili