Вопрос задан 30.10.2023 в 15:10.
Предмет Информатика.
Спрашивает Штебнер Илья.
Программа получает на вход натуральное число, большее 9. Вывести число, которое получится в
результате перестановки его последней и предпоследней цифр. ЯЗЫК C++Ответы на вопрос
Отвечает Черепахина Алёнка.
Код
- #include <iostream>
- #include <string>
- #include <functional>
- std::string switch_first_and_last(std::string N) {
- auto L = N.size() - 1;
- return N[L] + N.substr(1, L - 1) + N[0];
- }
- bool take_correct_number(int &number, const std::function<bool(int)>& Q) {
- do {
- std::cin >> number;
- if (!Q(number)) {
- std::cout << "Try again." << std::endl;
- continue;
- }
- break;
- } while (true);
- return true;
- }
- int main() {
- int number;
- take_correct_number(number, [](int x){return x > 9;});
- std::cout << switch_first_and_last(std::to_string(number)) << std::endl;
- }

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи на C++ мы можем использовать следующий код:
```cpp
#include
using namespace std;
int main() {
int number;
// Ввод натурального числа больше 9
cout << "Введите натуральное число больше 9: ";
cin >> number;
if (number <= 9) {
cout << "Число должно быть больше 9." << endl;
return 1; // Завершаем программу с ошибкой
}
// Извлекаем последнюю и предпоследнюю цифры
int lastDigit = number % 10;
int secondLastDigit = (number / 10) % 10;
// Вычисляем число после перестановки цифр
int resultNumber = lastDigit * 10 + secondLastDigit;
// Выводим результат
cout << "Число после перестановки: " << resultNumber << endl;
return 0; // Завершаем программу успешно
}
```
Этот код позволяет пользователю ввести натуральное число больше 9. Затем он извлекает последнюю и предпоследнюю цифры, выполняет перестановку и выводит полученное число. При вводе числа, которое не соответствует условию (меньше или равно 9), программа выдаст сообщение об ошибке и завершит выполнение.
0
0
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
