Вопрос задан 30.10.2023 в 06:13. Предмет Информатика. Спрашивает Узгенжанов Умарбек.

Написать программу в PascalABC.NET вычисления удвоенного произведения двух чисел и, если оно больше

10 - вычесть из него 5, иначе прибавить 20. ПОМОГИТЕ ПРОШУУУ
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Донова Олечка.

Ответ:

Program prog;

var a,b,c,d,e: integer;

f: real;

begin

writeln('Введите два числа');

readln(a);

readln(b);

e:=a*b;

e:= e * 2;

writeln('Произведение ',e);

if (e > 10) then e:= e - 10

else e:= e + 20;

writeln('Получилось ',e);

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, я могу помочь вам написать программу на PascalABC.NET для вычисления удвоенного произведения двух чисел и выполнения дополнительных действий в зависимости от результата. Вот пример программы: ```pascal program DoubleProductExample; var num1, num2, product, doubledProduct: real; begin // Ввод двух чисел writeln('Введите первое число: '); readln(num1); writeln('Введите второе число: '); readln(num2); // Вычисление произведения двух чисел product := num1 * num2; // Вычисление удвоенного произведения doubledProduct := 2 * product; writeln('Удвоенное произведение: ', doubledProduct); // Проверка условия и выполнение соответствующего действия if doubledProduct > 10 then begin doubledProduct := doubledProduct - 5; writeln('Результат после вычитания 5: ', doubledProduct); end else begin doubledProduct := doubledProduct + 20; writeln('Результат после прибавления 20: ', doubledProduct); end; end. ``` Эта программа сначала запрашивает у пользователя ввод двух чисел, затем вычисляет произведение и удвоенное произведение этих чисел. Далее, она проверяет условие: если удвоенное произведение больше 10, то из него вычитается 5; в противном случае к нему прибавляется 20. Результат выводится на экран.
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос