Дан массив из 8 целых чисел. составить программу вычисления суммы элементов массива меьнших 10
Ответы на вопрос
var a: array[1..8] of integer;
i,s: integer;
begin
randomize;
s:=0;
write('массив: ');
for i:=1 to 8 do begin
a[i]:=random(41)-20;
if a[i]<10 then s:=s+a[i];
write(a[i],' ');
end;
writeln;
write('сумма: ',s);
end.
===== PascalABC.NET =====
begin
var a := ArrRandom(8, -20, 20);
a.Println;
a.Where(p -> p < 10).Sum.Println
end.

Я попробую ответить на ваш вопрос. Дан массив из 8 целых чисел. Составить программу вычисления суммы элементов массива меньших 10.
Для решения этой задачи можно использовать следующий алгоритм:
- Объявить и инициализировать массив из 8 целых чисел, например, int arr[8] = {3, 7, 12, 9, 5, 11, 4, 6}; - Объявить и обнулить переменную для хранения суммы, например, int sum = 0; - Пройти по всем элементам массива в цикле, например, for (int i = 0; i < 8; i++) - Проверить, является ли текущий элемент меньше 10, например, if (arr[i] < 10) - Если да, то добавить его к сумме, например, sum += arr[i]; - Вывести результат на экран или в файл, например, cout << "Сумма элементов меньших 10 равна " << sum << endl;
На языке программирования C++ это может выглядеть так:
```cpp
#include
int main() { // Объявление и инициализация массива int arr[8] = {3, 7, 12, 9, 5, 11, 4, 6}; // Объявление и обнуление суммы int sum = 0; // Цикл по элементам массива for (int i = 0; i < 8; i++) { // Проверка условия if (arr[i] < 10) { // Добавление к сумме sum += arr[i]; } } // Вывод результата cout << "Сумма элементов меньших 10 равна " << sum << endl; return 0; } ```
Надеюсь, это поможет вам. Если у вас есть другие вопросы по программированию или другим темам, вы можете использовать мою функцию `search_web`, которая возвращает результаты поиска в интернете. Например, вы можете спросить меня `search_web("как нарисовать кота")` и я покажу вам ссылки на разные сайты и картинки по этой теме.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
