Вопрос задан 30.10.2023 в 01:06. Предмет Информатика. Спрашивает Антипова Юлия.

Исправьте программу bank, приведённую в учебных материалах, так, чтобы она работала правильно. Не

забудьте проверить и случай с 100000. Формат ввода Вводится одно число — величина вклада. Формат вывода Выводятся несколько строк — все сообщения программы, включая последнее (с суммой получаемых денег). Пример 1 Ввод Вывод 1000000 Добро пожаловать в интернет-банк! У нас фантастические процентные ставки! Для вкладов до 10 тысяч ₽ включительно прибыль составит 10%, для вкладов на сумму до 100 тысяч включительно - 20%, для более 100 тысяч - 30%! На какую сумму желаете сделать вклад? Вы получаете 1300000.0 ₽, поздравляем! Пример 2 Ввод Вывод 20000 Добро пожаловать в интернет-банк! У нас фантастические процентные ставки! Для вкладов до 10 тысяч ₽ включительно прибыль составит 10%, для вкладов на сумму до 100 тысяч включительно - 20%, для более 100 тысяч - 30%! На какую сумму желаете сделать вклад? Вы получаете 24000.0 ₽, поздравляем! на питоне
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Буткус Алеша.

Ответ:

Программа "bank" на языке Python.

Объяснение:

print('Добро пожаловать в интернет-банк!')

print('У нас фантастические процентные ставки!')

print('Для вкладов до 10 тысяч руб. включительно прибыль составит 10%,')

print('для вкладов на сумму до 100 тысяч включительно - 20%,')

print('для более 100 тысяч - 30%!')

print('На какую сумму желаете сделать вклад?')

rubles = float(input())

if rubles <= 10000:

   rubles *= 1.1

elif rubles <= 100000:

   rubles *= 1.2

elif rubles > 100000:

   rubles *= 1.3

print('Вы получаете', rubles, 'руб., поздравляем!')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Я могу помочь вам с поиском информации в Интернете, а также с созданием различного контента, такого как стихи, истории, код, эссе, песни, пародии на знаменитостей и многое другое.

Вы попросили меня ответить подробно и исправить программу bank, приведённую в учебных материалах, так, чтобы она работала правильно. Я нашёл несколько результатов поиска в Интернете, которые могут быть полезны для вас.

Вот один из них, который содержит пример программы на Python, использующей концепцию классов для создания банковского счёта с функциями депозита, снятия и отображения баланса. Вы можете использовать этот код как образец для своей программы.

Одна из проблем с вашей программой bank заключается в том, что она не учитывает случай, когда вклад равен 100000. В этом случае вы должны применить процентную ставку 20%, а не 30%. Другая проблема заключается в том, что вы используете оператор print для вывода сообщений и суммы получаемых денег, а не функцию return. Это делает вашу программу менее модульной и труднее тестировать.

Я попробовал исправить эти ошибки и получил следующий код:

```python # Программа bank def bank(deposit): print("Добро пожаловать в интернет-банк!") print("У нас фантастические процентные ставки!") print("Для вкладов до 10 тысяч ₽ включительно прибыль составит 10%,") print("для вкладов на сумму до 100 тысяч включительно - 20%,") print("для более 100 тысяч - 30%!") print("На какую сумму желаете сделать вклад?") if deposit <= 10000: profit = deposit * 0.1 elif deposit <= 100000: profit = deposit * 0.2 else: profit = deposit * 0.3 return deposit + profit

# Тестирование программы deposit = int(input()) result = bank(deposit) print("Вы получаете", result, "₽, поздравляем!") ```

Надеюсь, это поможет вам решить вашу задачу. Если у вас есть ещё какие-то вопросы или пожелания, я буду рад услышать их.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос