Вопрос задан 29.10.2023 в 12:18.
Предмет Информатика.
Спрашивает Соколовский Александр.
Написать программу , которая увеличивает число на 7, если оно меньше нуля и уменьшает на 2. Если
исходное число больше 0Ответы на вопрос
Отвечает Мирамбаева Арай.
Var a,b,c:integer;
begin
writeln('введите число');
readln(a);
if a<0 then b:=a+7 else b:=a-2;
if a=0 then while a=0 do begin writeln('введите другое число'); end;
writeln('полученное число ', b);
end.
begin
writeln('введите число');
readln(a);
if a<0 then b:=a+7 else b:=a-2;
if a=0 then while a=0 do begin writeln('введите другое число'); end;
writeln('полученное число ', b);
end.
Отвечает Евгеньевич Андрей.
var x : real;
begin
writeln ( 'Введите число : ');
readln (x);
if (x<0) then x:=x+7
else if (x>0) then x:=x-2;
writeln (' Конечное число : ',x);
end.
begin
writeln ( 'Введите число : ');
readln (x);
if (x<0) then x:=x+7
else if (x>0) then x:=x-2;
writeln (' Конечное число : ',x);
end.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
