Вопрос задан 28.10.2023 в 17:14.
Предмет Информатика.
Спрашивает Кирей Миша.
Составьте программы: 1. Определить является ли число чётным 2. Найти первую цифру 3-х значного
числа и определить делится ли она на 3Ответы на вопрос
Отвечает Пенкин Владимир.
1)var a:integer;
begin
writeln('Введите число');
readln(a);
if a mod 2=0 then writeln('Число чётное')
else writeln('Число нечётное');
end.
2)var a,b:integer;
begin
writeln('Введите число');
readln(a);
b:= a div 100;
if b>9 then writeln('Ошибка') else begin
writeln('Первая цифра это');
writeln (b);
if b mod 3=0 then writeln('Первая цифра числа делится на 3')
else writeln('Первая цифра числа не делится на 3');end;
end.
begin
writeln('Введите число');
readln(a);
if a mod 2=0 then writeln('Число чётное')
else writeln('Число нечётное');
end.
2)var a,b:integer;
begin
writeln('Введите число');
readln(a);
b:= a div 100;
if b>9 then writeln('Ошибка') else begin
writeln('Первая цифра это');
writeln (b);
if b mod 3=0 then writeln('Первая цифра числа делится на 3')
else writeln('Первая цифра числа не делится на 3');end;
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для выполнения данных задач вам потребуется написать программу на языке программирования. Я предоставлю примеры кода на Python для каждой из задач.
1. Определить является ли число четным:
```python
# Ввод числа с клавиатуры
number = int(input("Введите число: "))
# Проверка на четность
if number % 2 == 0:
print("Число", number, "является четным.")
else:
print("Число", number, "является нечетным.")
```
2. Найти первую цифру трехзначного числа:
```python
# Ввод трехзначного числа с клавиатуры
number = int(input("Введите трехзначное число: "))
# Находим первую цифру
first_digit = number // 100
print("Первая цифра трехзначного числа", number, "равна", first_digit)
```
3. Определить, делится ли первая цифра трехзначного числа на 3:
```python
# Ввод трехзначного числа с клавиатуры
number = int(input("Введите трехзначное число: "))
# Находим первую цифру
first_digit = number // 100
# Проверка на деление на 3
if first_digit % 3 == 0:
print("Первая цифра", first_digit, "делится на 3.")
else:
print("Первая цифра", first_digit, "не делится на 3.")
```
Вы можете вставить каждую из этих программ в вашу среду разработки (например, IDLE для Python) и запустить их, чтобы убедиться, что они работают правильно. Каждая программа решает одну из указанных вами задач.
0
0
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
