Вопрос задан 28.10.2023 в 07:38. Предмет Информатика. Спрашивает Гонин Никита.

1)Написать программу на языке Паскаль,которая вычисляет среднее арифметическое пяти любых чисел.

2) Написать программу на языке Паскаль,вычисляющую корни квадратного уравнения.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Авдеева Анастасия.
1)
program average;
var
    i: integer;
    answer, S, tmp: real;
begin
    for i := 1 to 5 do
    begin
        readln(tmp);
        S := S + tmp
    end;
    answer := S / 5;
    writeln(answer)
end.
2)
program equation;
var
    A, B, C, D, x1, x2: real;
begin
    writeln('ввеедите коэфициенты квадратного многочлена');
    readln(A);
    readln(B);
    readln(C);
    if A <> 0 then 
    begin 
    D := B*B - 4*A*C;
    if D < 0 then
        writeln('действительных корней нет')
    else if D = 0 then
    begin
        x1 := -B/(2*A);
        writeln('Единственный корень: ',x1)
    end else
    begin
        x1 := (-B + sqrt(D)) / (2*a);
        x2 := (-B - sqrt(D)) / (2*a);
        writeln('Два корня: ',x1,', ',x2)
    end;
    end
        else writeln('старший коэфициент не может равняться 0')
end.
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
1) Программа на языке Паскаль, которая вычисляет среднее арифметическое пяти любых чисел, может выглядеть следующим образом:

```pascal
program Average;

var
num1, num2, num3, num4, num5, average: real;

begin
writeln('Введите пять любых чисел:');
readln(num1, num2, num3, num4, num5);

average := (num1 + num2 + num3 + num4 + num5) / 5;

writeln('Среднее арифметическое: ', average);
end.
```

В данной программе мы создаем 6 переменных: num1, num2, num3, num4, num5 для хранения пяти любых чисел и переменную average для хранения среднего арифметического. Затем мы считываем пять чисел с помощью функции readln и вычисляем среднее арифметическое путем сложения их значений и деления на 5. Наконец, выводим результат с помощью функции writeln.

2) Программа на языке Паскаль, вычисляющая корни квадратного уравнения, может быть написана следующим образом:

```pascal
program QuadraticEquation;

var
a, b, c, discriminant, root1, root2: real;

begin
writeln('Введите коэффициенты уравнения:');
readln(a, b, c);

discriminant := b*b - 4*a*c;

if discriminant > 0 then
begin
root1 := (-b + sqrt(discriminant)) / (2*a);
root2 := (-b - sqrt(discriminant)) / (2*a);
writeln('Уравнение имеет два корня: ', root1, ' и ', root2);
end
else if discriminant = 0 then
begin
root1 := -b / (2*a);
writeln('Уравнение имеет один корень: ', root1);
end
else
begin
writeln('Уравнение не имеет действительных корней');
end;

end.
```

В данной программе мы создаем 7 переменных: a, b, c для хранения коэффициентов квадратного уравнения, discriminant для хранения дискриминанта и root1, root2 для хранения корней уравнения. Затем мы считываем коэффициенты уравнения и вычисляем дискриминант по формуле b^2 - 4ac. Затем с помощью условных операторов if-else проверяем значения дискриминанта и выводим соответствующие сообщения о количестве и значении корней. Если дискриминант больше нуля, то уравнение имеет два корня, если равен нулю - один корень, в противном случае уравнение не имеет действительных корней.
0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос