написать программу в которой пользователю предоставлено 3 товара, указана стоимость и количество. В
случае если пользователь ввел колличество товара и нажал кнопку купить, то колличество товара уменьшается, в случае нуля выдаёт окно о отсуствии товара с# Срочно надо!Ответы на вопрос
using System;
using System.Collections.Generic;
public class Program
{
public static void Main()
{
Dictionary<string, int> товары = new Dictionary<string, int>()
{
{ "Товар 1", 10 },
{ "Товар 2", 5 },
{ "Товар 3", 20 },
};
while(true)
{
Console.WriteLine("Доступные товары:");
foreach (var товар in товары)
{
Console.WriteLine($"Название: {товар.Key}, количество: {товар.Value}");
}
Console.Write("Введите название товара, который хотите купить: ");
string выбранныйТовар = Console.ReadLine();
if (товары.ContainsKey(выбранныйТовар))
{
if (товары[выбранныйТовар] > 0)
{
товары[выбранныйТовар]--;
Console.WriteLine($"Вы купили {выбранныйТовар}. Осталось {товары[выбранныйТовар]} штук.");
}
else
{
Console.WriteLine("Извините, этого товара нет в наличии.");
}
}
else
{
Console.WriteLine("Извините, вы ввели неправильное название товара.");
}
}
}
}
Ниже представлен пример кода программы:
```csharp
using System;
using System.Windows.Forms;
namespace ShopApplication
{
public partial class MainForm : Form
{
private int item1Count = 5; // количество товара 1
private int item2Count = 10; // количество товара 2
private int item3Count = 7; // количество товара 3
public MainForm()
{
InitializeComponent();
}
private void buyButton_Click(object sender, EventArgs e)
{
if (item1Count > 0 && item1Count >= Convert.ToInt32(textBox1.Text)) // проверка наличия товара 1
{
item1Count -= Convert.ToInt32(textBox1.Text); // уменьшение количества товара 1
MessageBox.Show("Товар 1 успешно куплен!");
}
else if (item1Count == 0)
{
MessageBox.Show("Товар 1 отсутствует!");
}
else if (Convert.ToInt32(textBox1.Text) > item1Count)
{
MessageBox.Show("Количество товара 1 превышает доступное значение!");
}
if (item2Count > 0 && item2Count >= Convert.ToInt32(textBox2.Text)) // проверка наличия товара 2
{
item2Count -= Convert.ToInt32(textBox2.Text); // уменьшение количества товара 2
MessageBox.Show("Товар 2 успешно куплен!");
}
else if (item2Count == 0)
{
MessageBox.Show("Товар 2 отсутствует!");
}
else if (Convert.ToInt32(textBox2.Text) > item2Count)
{
MessageBox.Show("Количество товара 2 превышает доступное значение!");
}
if (item3Count > 0 && item3Count >= Convert.ToInt32(textBox3.Text)) // проверка наличия товара 3
{
item3Count -= Convert.ToInt32(textBox3.Text); // уменьшение количества товара 3
MessageBox.Show("Товар 3 успешно куплен!");
}
else if (item3Count == 0)
{
MessageBox.Show("Товар 3 отсутствует!");
}
else if (Convert.ToInt32(textBox3.Text) > item3Count)
{
MessageBox.Show("Количество товара 3 превышает доступное значение!");
}
// Обновление отображения количества товаров
labelItem1Count.Text = item1Count.ToString();
labelItem2Count.Text = item2Count.ToString();
labelItem3Count.Text = item3Count.ToString();
}
}
}
```
В этом примере программа представляет графическую форму с 3 текстовыми полями для ввода количества товара и кнопкой "Купить". Также в форме есть 3 метки для отображения доступного количества товаров.
По умолчанию доступное количество товаров задано в переменных `item1Count`, `item2Count` и `item3Count`. При нажатии на кнопку "Купить", программа проверяет, доступен ли товар в нужном количестве, уменьшает его количество и выдает соответствующее сообщение.
После завершения покупки, программа обновляет отображение количества товаров на форме.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
