Вопрос задан 27.10.2023 в 21:32. Предмет Информатика. Спрашивает Агафонов Владислав.

Информатика! Нужно составить программу на языке паскаль. Мама выдала сыну Саше сумму денег Xна

карманные расходы. Ежедневно Саша в конце дня подводил итоги своим тратам и заносил их в программу. Требуется определить на сколько дней ему хватило денег и сколько денег осталось.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Кленкова Айша.

program raf105;

var mama,sum,rub,day:integer;

begin

write('Какую сумму денег мама выдала сыну? >> ');

readln(mama);

writeln('Введите сумму, которую вы потратили за один день');

writeln('Что бы узнать оставшиеся и потраченные деньги введите "-1"');

sum:=mama;

while sum<>0 do

begin

 readln(rub);

 if sum-rub >= 0  

   then

   if rub=-1  

     then

     begin

       writeln('У вас осталось ',sum,' руб.');

       writeln('Вы потратили ',mama-sum,' руб. за ',day,' дн.');

     end

     else

      begin

        sum:= sum-rub;

        day:= day+1;

      end

    else writeln('У вас недостаточно денег, что бы потратить такую сумму');

end;

writeln('У вас закончились деньги');

writeln('Вы потратили их за ',day,' дн.');

end.

Написано на языке PascalABC.NET

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Вот программа на языке Паскаль, которая позволяет определить на сколько дней хватило денег Саше и сколько денег осталось: ``` program MoneyManagement; var x, total, expenses, days: integer; begin writeln('Сумма денег на карманные расходы:'); readln(x); total := x; days := 0;

repeat writeln('Сколько денег потратил Саша сегодня? (0 для завершения)'); readln(expenses);

if expenses > 0 then begin total := total - expenses; days := days + 1; writeln('Остаток денег:', total); end; until expenses = 0;

writeln('Денег хватило на ', days, ' дней'); writeln('Остаток денег:', total);

readln; end. ```

Программа начинает с запроса суммы денег на карманные расходы у матери. Далее программа запрашивает ежедневные траты Саши и вычитает их из общей суммы. Также программа подсчитывает количество дней, когда были траты. Когда Саша вводит 0 в качестве траты, программа завершается и выводит количество дней, на которые хватило денег, и остаток денег.

Обратите внимание, что данная программа предполагает, что Саша каждый день подводит итоги своих трат, и вводит 0, когда закончил тратить деньги. Если Саша забудет вводить ежедневные траты или использует другую систему учета расходов, программа может работать некорректно.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос