Вопрос задан 27.10.2023 в 21:06. Предмет Информатика. Спрашивает Степашко Віка.

Написать программу в PascalABC с тарелками Шрёдингерапока дверь закрыта тарелки целы , иначе они

разбиты​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Смердов Максим.

var

a: string;

begin

writeln('"Дверь открыта?" -(Да или Нет)');

readln(a);

if (a='Да') or (a='да') then

writeln('Тарелки Шрёдингера разбиты!')

else

if (a='Нет') or (a='нет') then

writeln('Тарелки Шрёдингера целы!');

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, я могу помочь вам написать программу на языке PascalABC, имитирующую ситуацию с тарелками Шрёдингера. В данной задаче, пока дверь закрыта, мы не можем знать, целы тарелки внутри или разбиты. Давайте создадим простую программу, которая будет генерировать случайное состояние тарелок (целые или разбитые), пока дверь не будет открыта.

```pascal program SchrodingerPlates;

var plates: array[1..3] of string; // массив из трех тарелок doorClosed: boolean; // флаг, указывающий, закрыта ли дверь i: integer;

begin doorClosed := true; // начальное состояние - дверь закрыта Randomize; // инициализация генератора случайных чисел // инициализация состояния тарелок (целые или разбитые) for i := 1 to 3 do begin if Random(2) = 0 then // генерируем случайное число (0 или 1) plates[i] := 'целая' else plates[i] := 'разбитая'; end; // выводим состояние тарелок (но только если дверь закрыта) if doorClosed then begin writeln('Состояние тарелок:'); for i := 1 to 3 do writeln('Тарелка ', i, ': ', plates[i]); end else begin writeln('Дверь открыта, состояние тарелок неизвестно.'); end; readln; end. ```

В этой программе используется массив `plates`, содержащий состояния тарелок (целые или разбитые). Пока `doorClosed` установлен в `true`, программа будет генерировать случайные состояния тарелок и выводить их на экран. Как только дверь будет открыта, программа сообщит, что состояние тарелок неизвестно.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос