Написать программу на c# "Произвести суммирование натуральных чисел 1, 2, 3,..., пока их сумма s
не станет равной или превысит величину h. Вывести на экран последнее слагаемое и значение суммы."Ответы на вопрос
Написал на c++ т,к синтаксис шарпа не знаю, можешь переделать под себя.
#include "pch.h"
#include <iostream>
using namespace std;
int main()
{
setlocale(LC_ALL, "rus");
int summa = 0;
int h;
int i = 1;
cout << "Введите h" << endl;
cin >> h;
for(i;summa<h;)
{
summa += i;
i++;
}
cout <<"Сумма= "<< summa << endl <<"Последнее слагаемое = "<< i - 1 << endl;
}
Я попробую написать программу на C# для решения задачи. Вот мой код:
```csharp using System;
class Program { static void Main(string[] args) { // Вводим значение h с клавиатуры Console.WriteLine("Введите значение h:"); int h = int.Parse(Console.ReadLine());
// Инициализируем переменные для суммы и слагаемого int s = 0; int n = 1;
// Пока сумма меньше или равна h, добавляем слагаемое к сумме и увеличиваем слагаемое на 1 while (s <= h) { s += n; n++; }
// Выводим последнее слагаемое и значение суммы на экран Console.WriteLine("Последнее слагаемое: {0}", n - 1); Console.WriteLine("Значение суммы: {0}", s); } } ```
Я надеюсь, что это поможет вам.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
