
Турбо Паскаль. Написать программу, которая считает количество буквы в строке. Допустим букву "а" в
любом регистре, строка вводится с клавиатуры. входной файл: предложение выходной файл: количество буквы

Ответы на вопрос

uses Crt;
const
n=100; { мах длина строки }
var
s:string[n];
i,k:integer;
begin
ClrScr;
Readln(s);
k:=0;
for i:=1 to Length(s) do
if (s[i]='а') or (s[i]='А') then Inc(k);
Writeln(k);
ReadKey
end.



Для написания программы, которая будет считать количество буквы в строке, воспользуемся языком программирования Turbo Pascal.
В начале программы объявим переменные, которые будут использоваться:
```pascal var sentence: string; // переменная для хранения введенной строки letter: char; // символ, который мы будем искать count: integer; // переменная для хранения количества найденных символов ```
Затем, попросим пользователя ввести строку:
```pascal write('Введите строку: '); readln(sentence); ```
После этого, попросим пользователя ввести символ, который мы будем искать:
```pascal write('Введите символ: '); readln(letter); ```
Далее, проинициализируем переменную `count` нулем и начнем проверять каждый символ введенной строки. Если символ равен искомому символу `letter`, то увеличиваем переменную `count` на единицу:
```pascal count := 0; for i := 1 to length(sentence) do begin if sentence[i] = letter then count := count + 1; end; ```
Наконец, выведем результат:
```pascal writeln('Количество символов "', letter, '" в строке "', sentence, '": ', count); ```
Полный код программы будет выглядеть так:
```pascal program CountLetter;
var sentence: string; letter: char; count: integer;
begin write('Введите строку: '); readln(sentence); write('Введите символ: '); readln(letter); count := 0; for i := 1 to length(sentence) do begin if sentence[i] = letter then count := count + 1; end; writeln('Количество символов "', letter, '" в строке "', sentence, '": ', count); end. ```
После компиляции и запуска этой программы, она попросит ввести строку и символ, а затем выведет количество найденных символов `letter` в строке `sentence`.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili