Напишите программу для решения задачи с клавиатуры вводится целое 2-значное число ,если число
положительное то полочить новое число Z c перестановкой цифр исходного числа и вывести число Z на экран div и modОтветы на вопрос
PascalABC.NET 3.4.2, сборка 1847 от 28.10.2018
Внимание! Если программа не работает, обновите версию!
begin
var n := ReadInteger;
if n > 0 then
begin
var z := 10 * (n mod 10) + n div 10;
z.Println
end
end.
Ваша задача состоит в том, чтобы написать программу, которая принимает с клавиатуры 2-значное положительное число, затем меняет местами его цифры и выводит полученное число на экран. Для решения этой задачи можно использовать операторы деления и остатка от деления (div и mod в Pascal), а также функцию ввода и вывода (input и print в Python).
В Python это может выглядеть следующим образом:
```python # Ввод числа num = int(input("Введите 2-значное число: "))
# Проверка на 2-значность if num < 10 or num > 99: print("Введено не 2-значное число") else: # Получение цифр числа first_digit = num // 10 second_digit = num % 10
# Перестановка цифр new_num = second_digit * 10 + first_digit
# Вывод результата print("Новое число: ", new_num) ```
В этом коде мы сначала вводим число с клавиатуры. Затем проверяем, является ли оно 2-значным. Если это так, то мы извлекаем его цифры, меняем их местами и выводим результат.
Обратите внимание, что оператор `//` в Python выполняет деление с округлением вниз, а оператор `%` возвращает остаток от деления. Это позволяет нам получить цифры числа и затем переставить их местами.
В Pascal код будет выглядеть немного иначе, так как в этом языке для ввода и вывода используются функции `readln` и `writeln`, а для получения цифр числа - операции деления и взятия остатка от деления:
```pascal var num, first_digit, second_digit, new_num: integer; begin writeln('Введите 2-значное число: '); readln(num);
if (num < 10) or (num > 99) then writeln('Введено не 2-значное число') else begin first_digit := num div 10; second_digit := num mod 10;
new_num := second_digit * 10 + first_digit;
writeln('Новое число: ', new_num); end; end. ```
В этом коде мы делаем то же самое, что и в Python, но используем синтаксис Pascal.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
