ПОМОГИТЕЕЕЕ!!!! Написать программу на языке С (массивы) В классе 32 ученика, рост которых от 147
до 168 см. Написать программу, которая определила бы номер самого высокого ученика и его рост пожалуйста пожалуйста!!!!!!Ответы на вопрос
Ответ:
//Братишка, я тебе С++ принёс
#include <iostream>
/*
#include<cstdlib>
#include<ctime>
#include<cmath>*/
using namespace std;
/*
void fill(int arr[32]){
srand(time(NULL));
for(int i = 0;i<32;i++){
arr[i] = rand()%22 + 147;
}
}*/
int main()
{
int students[32];
//fill(students);
for(int i = 0;i<32;i++){
cin>>students[i];
}
int max_index = students[0];
for(int i = 0;i<32;i++){
if(students[i]>max_index){
max_index=i;
}
//Не обязательно
else{
continue;
}
}
cout<<"Рост:"<<students[max_index]<<endl;
cout<<"Номер:"<<max_index+1;
return 0;
}
Объяснение:
Код в комментариях нужен для автоматизации заполнения(чтобы не придумывать 32 числа)
Конечно, вот пример программы на языке C, которая поможет вам найти номер самого высокого ученика и его рост в классе:
c#include <stdio.h>
int main() {
int n = 32; // Количество учеников
int heights[n]; // Массив для хранения роста каждого ученика
int max_height = 0; // Переменная для хранения максимального роста
int max_height_student = 0; // Переменная для хранения номера ученика с максимальным ростом
// Ввод роста каждого ученика
for (int i = 0; i < n; i++) {
printf("Введите рост ученика %d (от 147 до 168 см): ", i + 1);
scanf("%d", &heights[i]);
// Проверка на допустимый диапазон роста
if (heights[i] < 147 || heights[i] > 168) {
printf("Рост должен быть от 147 до 168 см. Пожалуйста, введите корректное значение.\n");
i--; // Повторно вводим рост для текущего ученика
}
// Поиск максимального роста
if (heights[i] > max_height) {
max_height = heights[i];
max_height_student = i;
}
}
// Вывод результата
printf("Самый высокий ученик имеет номер %d и рост %d см.\n", max_height_student + 1, max_height);
return 0;
}
Эта программа запрашивает рост каждого ученика, проверяет, что рост находится в диапазоне от 147 до 168 см, и затем определяет номер самого высокого ученика и его рост.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
