Вопрос задан 25.10.2023 в 14:08.
Предмет Информатика.
Спрашивает Филатов Алексей.
Напишите программу в с++, которая в последовательности натуральных чисел определяет минимальное
число, оканчивающееся на 9. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Введённые числа не превышают по модулю 90 000. Если чисел, оканчивающееся на 9, нет, то вывести «NO».Ответы на вопрос
Отвечает Лейдерова Алёна.
Ответ:
#include <iostream>
#include<bits/stdc++.h>
using namespace std;
int main()
{
int min = INT_MAX,n;
cin>>n;
while (n != 0)
{
if (n%10==9)
{
if (n < min)
min = n;
}
cin>>n;
}
if (min == INT_MAX)
cout<<"No"<<endl;
else
cout<<"min = "<<min<<endl;
return 0;
}
Объяснение:


Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на C++, которая определяет минимальное число в последовательности натуральных чисел, оканчивающееся на 9:
cpp#include <iostream>
#include <climits>
int main() {
int minEndingWith9 = INT_MAX; // Используем максимальное значение int в качестве начального значения
while (true) {
int num;
std::cout << "Введите натуральное число (или 0 для завершения): ";
std::cin >> num;
if (num == 0) {
break; // Выход из цикла при вводе 0
}
if (num % 10 == 9 && num < minEndingWith9) {
minEndingWith9 = num;
}
}
if (minEndingWith9 == INT_MAX) {
std::cout << "NO" << std::endl;
} else {
std::cout << "Минимальное число, оканчивающееся на 9: " << minEndingWith9 << std::endl;
}
return 0;
}
Эта программа будет продолжать запрашивать натуральные числа до тех пор, пока не будет введен 0. После этого она выведет минимальное число, оканчивающееся на 9, или "NO", если таких чисел в последовательности не было введено.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 31
Информатика 36
Информатика 24
Информатика 43
Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
