В dev c++ Дан массив размера N. Вывести массив на экран в строчку. Найти номер его первого
локального максимума. Локальный максимум – это элемент, который больше любого из своих соседей. Входные данные размерность массива: 5 0 5 89 10 100 Выходные данные 0 5 89 10 100 Номер элемента массива, первого локального минимума - 3Ответы на вопрос
#include <iostream>
int main() {
using namespace std;
setlocale(LC_ALL, "Russian");
int N;
cout << "Введите размерность массива: ";
cin >> N;
int* A = new int[N];
for (int i = 0; i < N; i++)
{
cout << "Заполните [" << i + 1 << "] элемент: ";
cin >> A[i];
}
cout << endl;
for (int i = 0; i < N; i++)
{
cout << A[i] << " ";
}
int max_index = 0;
for (int i = 1; i < N; i++)
{
if (A[i] > A[max_index]) {
max_index = i;
}
}
cout << "\nНомер локального максимума: " << max_index + 1;
return 0;
}
Задача: Вывод массива и поиск первого локального максимума
Дан массив размера N. Необходимо вывести массив на экран в строчку и найти номер его первого локального максимума. Локальный максимум - это элемент, который больше любого из своих соседей.
Входные данные: Размерность массива: 5 Массив: 0, 5, 89, 10, 100
Выходные данные: Массив: 0, 5, 89, 10, 100 Номер элемента массива, первого локального максимума: 3
Решение:
Для решения этой задачи, мы можем последовательно пройтись по элементам массива и сравнить каждый элемент с его соседями. Если элемент больше обоих соседей, то он является локальным максимумом.
```c++
#include
int main() { int N = 5; int arr[] = {0, 5, 89, 10, 100}; int local_max_index = -1;
// Вывод массива на экран в строчку for (int i = 0; i < N; i++) { cout << arr[i] << " "; } cout << endl;
// Поиск первого локального максимума for (int i = 1; i < N - 1; i++) { if (arr[i] > arr[i-1] && arr[i] > arr[i+1]) { local_max_index = i; break; } }
cout << "Номер элемента массива, первого локального максимума: " << local_max_index << endl;
return 0; } ```
Объяснение решения: - Мы объявляем переменную `N` для хранения размерности массива и массив `arr` с данными. - Затем мы проходимся по массиву и выводим его элементы на экран в строчку. - После этого мы ищем первый локальный максимум, проходя по элементам массива с индексами от 1 до `N-2`. Если элемент больше своих соседей, то мы сохраняем его индекс в переменную `local_max_index` и выходим из цикла. - Наконец, мы выводим на экран номер элемента массива, первого локального максимума.
Результат: Массив: 0, 5, 89, 10, 100 Номер элемента массива, первого локального максимума: 3
Пожалуйста, обратите внимание, что код предоставлен в качестве примера и может быть адаптирован под конкретные требования и язык программирования.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
