Вопрос задан 25.10.2023 в 03:01.
Предмет Информатика.
Спрашивает Петрова Анастасия.
Составить программу на Паскале: Ввести с клавиатуры строку. приписать к ней фразу "ПРИВЕТ", начиная
с 4 символа исходной строкиОтветы на вопрос
Отвечает Терзи Иван.
Если правильно тебя понял, то вот такой код.
var str,str1:string;
I:integer;
begin
Read(str);
str1:=str[1] + str[2] + str[3] + 'Привет!';
for I:=4 to length(str) do
begin
str1:=str1 + str[i];
end;
Writeln(str1);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Паскаль, который выполняет указанные вами действия:
pascalprogram AddString; var OriginalString, AddedString: string; Position: integer; begin // Вводим строку с клавиатуры writeln('Введите строку:'); readln(OriginalString); // Проверяем, что исходная строка имеет длину больше или равную 4 if length(OriginalString) >= 4 then begin // Выделяем подстроку с 4-го символа исходной строки до конца строки AddedString := copy(OriginalString, 4, length(OriginalString) - 3); // Приписываем к полученной подстроке фразу "ПРИВЕТ" AddedString := AddedString + 'ПРИВЕТ'; // Выводим исходную строку и новую строку writeln('Исходная строка: ', OriginalString); writeln('Новая строка: ', AddedString); end else writeln('Строка слишком короткая. Введите строку длиной не менее 4 символов.'); end.
Пожалуйста, учтите, что в этой программе предполагается, что введенная строка имеет длину не менее 4 символов. Если введенная строка короче, программа выведет сообщение об ошибке.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
