Программирование на С++ Дан двумерный массив целых чисел 7x7. Составить программу:а) которая
определяет, есть ли в некоторой строке массива хотя бы один элемент, равный заданному числу;б) которая определяет, есть ли в некотором столбце массива хотя бы один элемент, кратный заданному числу.Ответы на вопрос
Ответ:
Для программы а удалите часть, выделенную комментарием "программа б"
Для программы б удалите часть, выделенную комментарием "программа а"
#include <iostream>
#include <iomanip>
#include <ctime>
int main()
{
int i,j, a, k;
int A[7][7];
setlocale(LC_ALL, "Russian"); // Русский язык в консоли
srand(time(0));
for (i = 0; i < 7; i++)
{
for (j = 0; j < 7; j++)
{
A[i][j] = rand() % 100;
std::cout << std::setw(5) << A[i][j];
}
std::cout << std::endl;
}
// Программа a
std::cout << "Введите строку и число через пробел: ";
std::cin >> k >> a;
for (j = 0; j < 7; j++)
if (A[k-1][j] == a)
{
std::cout << "Есть";
break;
}
if (j==7) std::cout << "Нет";
// Программа a
// Программа б
std::cout << "Введите столбец и число через пробел: ";
std::cin >> k >> a;
for (i = 0; i < 7; i++)
if (A[i][k-1] % a == 0)
{
std::cout << "Есть";
break;
}
if (i == 7) std::cout << "Нет";
// Программа б
return 0;
}
Для выполнения этих задач вам потребуется написать программу на C++, которая будет проверять двумерный массив целых чисел 7x7 на соответствие заданным условиям. Ниже приведен пример программы, которая решает обе задачи:
```cpp
#include
int main() { // Создаем двумерный массив 7x7 целых чисел int array[7][7] = { {1, 2, 3, 4, 5, 6, 7}, {8, 9, 10, 11, 12, 13, 14}, {15, 16, 17, 18, 19, 20, 21}, {22, 23, 24, 25, 26, 27, 28}, {29, 30, 31, 32, 33, 34, 35}, {36, 37, 38, 39, 40, 41, 42}, {43, 44, 45, 46, 47, 48, 49} };
// Заданные числа для поиска int numberToFindInRow = 30; int numberToFindInColumn = 4;
// Флаги для проверки наличия чисел в строке и столбце bool foundInRow = false; bool foundInColumn = false;
// Поиск в строке for (int i = 0; i < 7; ++i) { for (int j = 0; j < 7; ++j) { if (array[i][j] == numberToFindInRow) { foundInRow = true; break; } } if (foundInRow) { break; } }
// Поиск в столбце for (int j = 0; j < 7; ++j) { for (int i = 0; i < 7; ++i) { if (array[i][j] % numberToFindInColumn == 0) { foundInColumn = true; break; } } if (foundInColumn) { break; } }
// Вывод результатов if (foundInRow) { std::cout << "В массиве есть элемент, равный " << numberToFindInRow << " в какой-то строке." << std::endl; } else { std::cout << "В массиве нет элемента, равного " << numberToFindInRow << " в какой-либо строке." << std::endl; }
if (foundInColumn) { std::cout << "В массиве есть элемент, кратный " << numberToFindInColumn << " в каком-то столбце." << std::endl; } else { std::cout << "В массиве нет элемента, кратного " << numberToFindInColumn << " в каком-либо столбце." << std::endl; }
return 0; } ```
Программа сначала создает двумерный массив, а затем выполняет поиск указанных чисел в строках и столбцах массива. Результаты поиска выводятся на экран. Вы можете заменить значения `numberToFindInRow` и `numberToFindInColumn` на те, которые вам нужны для вашей задачи.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
