составить программу которая будет находить все простые числа из промежутка от 4 до 60. Использовать
рекурсивную функцию. ПаскальОтветы на вопрос
Ответ:
procedure recursiveprime(num:integer);
var
i:integer;
begin
{тупая проверка *числа* на простоту - пытаемся поделить на все числа от 2 до *числа*/2)
i:=2;
while i<(num div 2) and (num mod i <> 0) do inc(i)
if i=num div 2 then println(num,"- простое!');
if num<60 then recursiveprime(num+1);
end;
begin
recursiveprime(4);
end.
Объяснение:
ну как-то так.. паскаля под рукой нет, лет 7 назад последний раз трогал дельфи
рекурсивная процедура которая вызывает саму себя со следующим числом если переданое ему число меньше 60
проверка на простоту - пытаемся поделить на все числа от 2 до половины проверяемого числа и проверяем остатки.
надеюсь мысль понятна
Вот пример программы на языке Паскаль, которая использует рекурсивную функцию для поиска всех простых чисел в заданном диапазоне от 4 до 60:
pascalprogram FindPrimes; function IsPrime(n: Integer; divisor: Integer): Boolean; begin if (n <= 2) then IsPrime := False else if (divisor = 2) then IsPrime := True else if (n mod divisor = 0) then IsPrime := False else IsPrime := IsPrime(n, divisor - 1); end; procedure FindPrimesInRange(start, limit: Integer); begin if (start > limit) then Exit; if IsPrime(start, Trunc(Sqrt(start))) then Write(start, ' '); FindPrimesInRange(start + 1, limit); end; begin Write('Prime numbers in the range from 4 to 60: '); FindPrimesInRange(4, 60); writeln; end.
Эта программа определяет функцию IsPrime, которая использует рекурсию для проверки, является ли число простым. Затем она вызывает функцию FindPrimesInRange, которая выводит все простые числа в заданном диапазоне.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
