ПАСКАЛЬ 1.составить программу которая проверяет четное ли это число 2.составить программу которая
уравнивает два числа a и b 3.составить программу которая проверяет трехзначное ли это числоОтветы на вопрос
1)
var
num: integer;
begin
writeln('Введите число');
read(num);
if(num mod 2 = 0) then
write('Число четное')
else
write('Число нечетное');
end.
2)
var
a, b, i: integer;
begin
writeln('Введите a');
read(a);
writeln('Введите b');
read(b);
if (a > b) then
swap(a, b);
for i := 0 to
b - a - 1 do
a := a + 1;
end.
3)
var
num: integer;
begin
writeln('Введите число');
read(num);
if (num div 1000 = 0) and (num div 100 <> 0) then
write('Число трехзначное')
else
write('Число не трехзначное');
end.
Вот примеры программ на языке Pascal для выполнения каждой из указанных задач:
- Проверка на четность числа:
pascalprogram CheckEven; var num: integer; begin write('Введите число: '); readln(num); if num mod 2 = 0 then writeln('Число четное.') else writeln('Число нечетное.'); end.
- Уравнивание двух чисел a и b:
pascalprogram EqualizeNumbers; var a, b: integer; begin write('Введите число a: '); readln(a); write('Введите число b: '); readln(b); if a = b then writeln('Числа a и b равны.') else begin writeln('Числа a и b различны. Уравниваем их.'); a := b; writeln('Теперь a = ', a); end; end.
- Проверка на трехзначность числа:
pascalprogram CheckThreeDigitNumber; var num: integer; begin write('Введите число: '); readln(num); if (num >= 100) and (num <= 999) then writeln('Это трехзначное число.') else writeln('Это не трехзначное число.'); end.
Вы можете скопировать и вставить каждую из этих программ в среду разработки Pascal (например, Lazarus) и выполнить их для проверки.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
