Вопрос задан 24.10.2023 в 03:43.
Предмет Информатика.
Спрашивает Тыныштықов Данабек.
Написать программу в Паскале по задаче: Вычислить сумму положительных и отрицательных элементов
массива k(12), заполненного с клавиатурыОтветы на вопрос
Отвечает Щурина Карина.
var s,i: integer;
k:array [1..100] of integer;
begin
for i := 1 to 12 do
begin
readln(k[i]);
s :=s + k[i];
end;
writeln('Ответ: ' + s);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот программа на языке Паскаль, которая вычисляет сумму положительных и отрицательных элементов массива k(12), заполненного с клавиатуры:
pascalprogram SumOfPositiveAndNegativeElements; var k: array[1..12] of integer; i, positiveSum, negativeSum: integer; begin positiveSum := 0; negativeSum := 0; writeln('Введите элементы массива k(12):'); for i := 1 to 12 do begin write('k[', i, ']: '); readln(k[i]); if k[i] > 0 then positiveSum := positiveSum + k[i] else negativeSum := negativeSum + k[i]; end; writeln('Сумма положительных элементов: ', positiveSum); writeln('Сумма отрицательных элементов: ', negativeSum); readln; end.
Эта программа создает массив k из 12 элементов и заполняет его значениями, введенными пользователем с клавиатуры. Затем она вычисляет сумму положительных и отрицательных элементов массива и выводит результаты на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 11
Информатика 1255
Информатика 115
Информатика 1220
Информатика 11
Информатика 10
Информатика 66
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
