Составить программу которая определяет вторую цифру четырёхзначного числа, и заменяет её на 4
Ответы на вопрос
ch,otv,perv,last:Integer;
begin
WriteLn('Введите число');
readln(ch);
last:=ch mod 100;
ch:=ch div 100;
perv:= ch div 10;
ch:=ch div 10;
otv := perv*1000+4*100+last;
WriteLn('Ответ: ',otv)
end.
пж как лучший
Для решения этой задачи можно использовать язык программирования Python. Сначала, необходимо получить четырехзначное число от пользователя. Затем, преобразовать это число в строку, чтобы можно было легко заменить вторую цифру на 4. В конце, преобразовать строку обратно в число.
Вот шаги, которые можно следовать:
1. Получить четырехзначное число от пользователя. 2. Преобразовать число в строку. 3. Заменить вторую цифру на 4. 4. Преобразовать строку обратно в число. 5. Вывести полученное число.
Вот пример кода, который выполняет эти шаги:
```python # Шаг 1: Получить четырехзначное число от пользователя number = int(input("Введите четырехзначное число: "))
# Шаг 2: Преобразовать число в строку number_str = str(number)
# Шаг 3: Заменить вторую цифру на 4 number_str = number_str[:1] + '4' + number_str[2:]
# Шаг 4: Преобразовать строку обратно в число number = int(number_str)
# Шаг 5: Вывести полученное число print("Новое число: ", number) ```
Примечание: Этот код предполагает, что пользователь всегда вводит четырехзначное число. Если это не так, код может работать некорректно.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
