Вопрос задан 23.10.2023 в 15:43.
Предмет Информатика.
Спрашивает Редько Ваня.
Написать программу вычисления суммы целых чисел от 1 до n, запрашиваемого с клавиатуры. Pascal ABC
Ответы на вопрос
Отвечает Бурик Артём.
Var
i, n: integer;
sum: longint;
begin
write('n = ');
readln(n);
for i := 1 to n do sum := sum + i;
writeln('Сумма чисел от 1 до ', n , ' = ', sum);
end.
i, n: integer;
sum: longint;
begin
write('n = ');
readln(n);
for i := 1 to n do sum := sum + i;
writeln('Сумма чисел от 1 до ', n , ' = ', sum);
end.
Отвечает Майер Лея.
Var
s,n:integer;
begin
Write('Введите n:');
Readln(n);
s:=n+(n*(n-1)) div 2; { сумма арифметической прогрессии }
Writeln('Сумма чисел от 1 до ',n,' равна ',s)
end.
s,n:integer;
begin
Write('Введите n:');
Readln(n);
s:=n+(n*(n-1)) div 2; { сумма арифметической прогрессии }
Writeln('Сумма чисел от 1 до ',n,' равна ',s)
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на Pascal ABC, которая вычисляет сумму целых чисел от 1 до заданного пользователем числа n:
pascalprogram SumOfIntegers; var n, sum, i: integer; begin sum := 0; // Инициализируем сумму нулем // Запрашиваем у пользователя число n write('Введите число n: '); readln(n); // Вычисляем сумму целых чисел от 1 до n for i := 1 to n do sum := sum + i; // Выводим результат writeln('Сумма целых чисел от 1 до ', n, ' равна ', sum); readln; // Чтобы окно программы не закрывалось сразу end.
Эта программа сначала запрашивает у пользователя число n, затем использует цикл for для вычисления суммы целых чисел от 1 до n, и, наконец, выводит результат на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
