Вопрос задан 23.10.2023 в 07:03.
Предмет Информатика.
Спрашивает Протченко Данил.
Паскаль. подсчитать сколько букв начинается с последней буквы первого слова
Ответы на вопрос
Отвечает Мелехин Артём.
// PascalABC.NET 3.2, сборка 1407 от 18.03.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadlnString('Вводите:').ToWords;
var c:=a[0].Last;
Writeln('Найдено ',a.Where(w->w.First=c).Count,
' слов, начинающихся с "',c,'"')
end.
Пример
Вводите: Туча дождь астроном баран арбуз зебра астра велосипед
Найдено 3 слов, начинающихся с "а"
Вариант "а нас в школе учат так", который якобы "проще"
var
s:string;
c:char;
i,k,l,p:integer;
begin
// Предполагается, что слова разделены ровно одним пробелом
Write('Вводите: '); Readln(s);
l:=Length(s);
if l=1 then Writeln('Найдено одно слово')
else begin
p:=Pos(' ',s);
if (p=0) and (s[1]=s[l]) then Writeln('Найдено одно слово')
else begin
c:=s[p-1];
if s[1]=c then k:=1 else k:=0;
for i:=p+1 to Length(s)-1 do
if (s[i]=' ') and (s[i+1]=c) then Inc(k);
Writeln('Найдено ',k,' слов, начинающихся с "',c,'"')
end
end
end.
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ReadlnString('Вводите:').ToWords;
var c:=a[0].Last;
Writeln('Найдено ',a.Where(w->w.First=c).Count,
' слов, начинающихся с "',c,'"')
end.
Пример
Вводите: Туча дождь астроном баран арбуз зебра астра велосипед
Найдено 3 слов, начинающихся с "а"
Вариант "а нас в школе учат так", который якобы "проще"
var
s:string;
c:char;
i,k,l,p:integer;
begin
// Предполагается, что слова разделены ровно одним пробелом
Write('Вводите: '); Readln(s);
l:=Length(s);
if l=1 then Writeln('Найдено одно слово')
else begin
p:=Pos(' ',s);
if (p=0) and (s[1]=s[l]) then Writeln('Найдено одно слово')
else begin
c:=s[p-1];
if s[1]=c then k:=1 else k:=0;
for i:=p+1 to Length(s)-1 do
if (s[i]=' ') and (s[i+1]=c) then Inc(k);
Writeln('Найдено ',k,' слов, начинающихся с "',c,'"')
end
end
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для того чтобы подсчитать сколько слов начинается с последней буквы первого слова в тексте на Паскале, вам потребуется написать программу. Вот пример кода на Паскале, который сделает это:
pascalprogram CountWordsStartingWithLastLetter; var text: string; lastLetter: char; wordCount: integer; i: integer; begin wordCount := 0; // Ввод текста writeln('Введите текст:'); readln(text); // Проверяем, не пустой ли текст if Length(text) = 0 then begin writeln('Текст пуст.'); exit; end; // Получаем последнюю букву первого слова lastLetter := text[1]; // Разбиваем текст на слова и считаем слова, начинающиеся с последней буквы первого слова i := 1; while i <= Length(text) do begin // Пропускаем пробелы while (i <= Length(text)) and (text[i] = ' ') do Inc(i); // Начало нового слова if (i <= Length(text)) and (UpCase(text[i]) = UpCase(lastLetter)) then begin Inc(wordCount); // Продолжаем двигаться до конца слова while (i <= Length(text)) and (text[i] <> ' ') do Inc(i); end else begin // Продолжаем двигаться до конца слова while (i <= Length(text)) and (text[i] <> ' ') do Inc(i); end; end; writeln('Количество слов, начинающихся с последней буквы первого слова: ', wordCount); end.
Эта программа считывает текст, получает последнюю букву первого слова, а затем разбивает текст на слова, считая слова, начинающиеся с этой буквы. Результат будет выведен на экран.
Похожие вопросы
Информатика 138
Информатика 162
Топ вопросов за вчера в категории Информатика
Информатика 437
Информатика 11
Информатика 10
Информатика 44
Информатика 23
Информатика 43
Информатика 63
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
