Вопрос задан 22.10.2023 в 14:56. Предмет Информатика. Спрашивает Пономарев Никита.

Составьте программу нахождения наибольшего значения роста у двух членов школьной баскетбольной

команды (рост спортсменов вводится с клавиатуры).
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Гринь Полина.

Uses
  Crt;
Var
  i, N, kol: byte;
  sum_rost, sr_rost: real;
  team: array[1..100] of real;
Begin
  sum_rost := 0.0;
  sr_rost := 0.0;
  kol := 0;
  write('Введите количество членов команды');
  read(N);
  writeln('Введите рост каждого члена команды');
  for i := 1 to N do
    begin
      readln(team[i]);
      sum_rost := sum_rost + team[i];
    end;
  sr_rost := sum_rost / N;
  for i := 1 to N do
    if (team[i] > sr_rost) then
      kol := kol + 1;
  writeln('Количество членов команды, рост которых превышает средний по команде (', sr_rost:4:2, ')');
  write(' равно ', kol);
End.

Прошу. Я надеюсь надо было на паскале написать?)

 

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для нахождения наибольшего значения роста двух членов школьной баскетбольной команды, вы можете воспользоваться следующей программой на языке Python:

python
# Ввод роста первого игрока рост_игрока1 = float(input("Введите рост первого игрока (в см): ")) # Ввод роста второго игрока рост_игрока2 = float(input("Введите рост второго игрока (в см): ")) # Нахождение наибольшего роста наибольший_рост = max(рост_игрока1, рост_игрока2) # Вывод результата print("Наибольший рост среди игроков: {} см".format(наибольший_рост))

Эта программа сначала запрашивает рост двух игроков у пользователя, затем сравнивает их рост и выводит наибольший рост на экран.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос