Вопрос задан 20.10.2023 в 05:19.
Предмет Информатика.
Спрашивает Романова Софья.
Составить программу, которая меняет элементы массива на противоположные по знаку, массив
заполняется с клавиатуры. Решить задачу на паскале.Ответы на вопрос
Отвечает Гумиров Айназ.
PascalABC
var a:array of real;
i,n:integer;
begin
write('Задайте размер массива = ');readln(n);
setlength(a,n);
for i:=0 to n-1 do readln(a[i]);
writeln('Исходный массив: ',a);
for i:=0 to n-1 do a[i]:= -a[i];
writeln('Полученный массив: ',a);
end.
var a:array of real;
i,n:integer;
begin
write('Задайте размер массива = ');readln(n);
setlength(a,n);
for i:=0 to n-1 do readln(a[i]);
writeln('Исходный массив: ',a);
for i:=0 to n-1 do a[i]:= -a[i];
writeln('Полученный массив: ',a);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот программа на языке Pascal, которая меняет знаки элементов массива на противоположные. Массив заполняется с клавиатуры:
pascalprogram InvertArrayElements; var arr: array of Integer; n, i: Integer; begin Write('Введите размер массива: '); Readln(n); SetLength(arr, n); // Ввод элементов массива с клавиатуры for i := 0 to n - 1 do begin Write('Введите элемент массива №', i + 1, ': '); Readln(arr[i]); end; // Инвертирование знаков элементов for i := 0 to n - 1 do begin arr[i] := -arr[i]; end; // Вывод измененного массива Writeln('Измененный массив:'); for i := 0 to n - 1 do begin Write(arr[i], ' '); end; end.
Эта программа запрашивает у пользователя размер массива и элементы, а затем инвертирует знаки элементов и выводит измененный массив.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
