Вопрос задан 18.10.2023 в 12:27.
Предмет Информатика.
Спрашивает Тюленева Арина.
Составьте программу вычисления в массиве В, состоящем из восьми элементов, суммы отрицательных
элементов. паскальОтветы на вопрос
Отвечает Кузнецов Миша.
var a,b,sum:integer;
arr :array [0..7] of integer;
begin
sum:=0;
write('введите элементы массива : ');
for a:=0 to 7 do begin
read(b);
arr[a]:=b;
end;
for a:=0 to 7 do begin
if arr[a]<0 then sum:=sum+arr[a];
end;
writeln('сумма отрицательных элементов массива = ',sum);
end.
arr :array [0..7] of integer;
begin
sum:=0;
write('введите элементы массива : ');
for a:=0 to 7 do begin
read(b);
arr[a]:=b;
end;
for a:=0 to 7 do begin
if arr[a]<0 then sum:=sum+arr[a];
end;
writeln('сумма отрицательных элементов массива = ',sum);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вот пример программы на языке Pascal, который вычисляет сумму отрицательных элементов в массиве В, состоящем из восьми элементов:
pascalprogram SumOfNegativeElements; var B: array[1..8] of Integer; i, sum: Integer; begin sum := 0; writeln('Введите восемь элементов массива B:'); for i := 1 to 8 do begin write('B[', i, '] = '); readln(B[i]); if B[i] < 0 then sum := sum + B[i]; end; writeln('Сумма отрицательных элементов в массиве B: ', sum); end.
Эта программа позволяет пользователю ввести восемь элементов массива B и затем вычисляет сумму всех отрицательных элементов в массиве.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
