Вопрос задан 09.10.2023 в 05:43.
Предмет Информатика.
Спрашивает Быкова Виктория.
Помогите, пожалуйста! Через паскаль! Тема: «Поиск наибольшего или наименьшего элемента массива»
Написать программу, которая определяет наибольшее по модулю число в массиве из 10 введенных пользователем чисел. Не использовать: const, count и другие, которые не по теме!Ответы на вопрос
Отвечает Мустафина Камила.
Var a: array[0..10] of Integer;
i,n,m: Integer;
begin
m:=0;
for i:=0 to 9 do
begin
writeln('Введите ',i+1,' число');
readln(n);
a[i]:=abs(n);
end;
for i:=0 to 9 do
begin
if m<a[i] then m:=a[i];
end;
writeln('Самое большое число в массиве :',m);
end.
i,n,m: Integer;
begin
m:=0;
for i:=0 to 9 do
begin
writeln('Введите ',i+1,' число');
readln(n);
a[i]:=abs(n);
end;
for i:=0 to 9 do
begin
if m<a[i] then m:=a[i];
end;
writeln('Самое большое число в массиве :',m);
end.
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот пример программы на языке Pascal, которая находит наибольшее по модулю число в массиве из 10 введенных пользователем чисел, без использования const, count и других дополнительных функций:
pascalprogram FindMaxAbsoluteValue; var numbers: array[1..10] of integer; i, maxAbsoluteValue, currentAbsoluteValue: integer; begin writeln('Введите 10 целых чисел:'); for i := 1 to 10 do begin write('Число ', i, ': '); readln(numbers[i]); end; maxAbsoluteValue := abs(numbers[1]); // Инициализируем начальное максимальное значение for i := 2 to 10 do begin currentAbsoluteValue := abs(numbers[i]); if currentAbsoluteValue > maxAbsoluteValue then maxAbsoluteValue := currentAbsoluteValue; end; writeln('Наибольшее по модулю число: ', maxAbsoluteValue); readln; end.
Эта программа сначала запрашивает у пользователя 10 целых чисел и сохраняет их в массиве numbers. Затем она проходит по массиву, вычисляя абсолютное значение каждого элемента и сравнивая его с текущим максимальным абсолютным значением. Если текущее значение больше, оно становится новым максимальным абсолютным значением. В конце программа выводит наибольшее по модулю число.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 22
Информатика 16
Информатика 13
Информатика 14
Информатика 29
Информатика 15
Информатика 17
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
