
Вопрос задан 09.10.2023 в 02:51.
Предмет Информатика.
Спрашивает Михалицька Соня.
Паскаль: написать программу выводит первую цифру 2-х значного числа


Ответы на вопрос

Отвечает Агапова Тома.
var
n: Integer;
begin
Write('Число: ');
readln(n);
if (n > 9) and (n < 100) then
begin
n := n div 10;
WriteLn('Первая цифра числа - ', n);
end
else
WriteLn('Число не 2-хзначное');
end.



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот простая программа на Pascal, которая выводит первую цифру двузначного числа:
pascalprogram FirstDigit; var number: integer; firstDigit: integer; begin // Ввод двузначного числа write('Введите двузначное число: '); readln(number); // Проверка на двузначность числа if (number < 10) or (number > 99) then begin writeln('Введенное число не является двузначным.'); end else begin // Вычисление первой цифры firstDigit := number div 10; // Вывод результата writeln('Первая цифра: ', firstDigit); end; end.
Просто скопируйте этот код в среду программирования Pascal и выполните его.


Похожие вопросы
Топ вопросов за вчера в категории Информатика

Информатика 575

Информатика 33

Информатика 39

Информатика 24

Информатика 34

Информатика 136

Информатика 18
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili