Вопрос задан 08.10.2023 в 00:30. Предмет Информатика. Спрашивает Олейник Даниил.

PASCAL!!!!!!!!! Написать программу, выводящую номер этажа, где расположена квартира, если

известно, что в этажном доме один подъезд, на четных этажах по 7 квартир, на нечетных – 5, при этом на первом этаже квартир нет. При входе в дом вводится номер квартиры. В случае ошибочного ввода номера квартиры, программа должна сообщать об этом.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Волошкин Макс.
A - номер квартиры, начиная с 1
n - этаж

C:
n = 2*((a-1)/12)+2+((а-1)%12)/7

Pascal:
n := 2*((a-1) div 12)+2+((a-1) mod 12) div 7

выражение в одну строку
% это остаток от деления
a и n переменные целого типа, подразумевается, что происходит автоматическое округление при делении в меньшую сторону
0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на языке Pascal, которая решает вашу задачу:

pascal
program ApartmentFloorCalculator; var apartmentNumber, floorNumber: integer; begin writeln('Введите номер квартиры: '); readln(apartmentNumber); if apartmentNumber < 1 then writeln('Ошибка: Номер квартиры должен быть больше 0') else begin floorNumber := (apartmentNumber - 1) div 12 + 2; if (floorNumber mod 2 = 0) then begin floorNumber := floorNumber div 2; writeln('Квартира находится на ', floorNumber, ' четаже.'); end else begin floorNumber := (floorNumber + 1) div 2; writeln('Квартира находится на ', floorNumber, ' нечетаже.'); end; end; end.

Эта программа запрашивает у пользователя номер квартиры и затем вычисляет номер этажа, на котором расположена эта квартира. При вводе номера квартиры, равного или меньшего 0, программа выдаст ошибку. В противном случае она рассчитает номер этажа согласно вашим условиям и выведет результат.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос