Вопрос задан 07.10.2023 в 09:54.
Предмет Информатика.
Спрашивает Сумской Руслан.
Напишите программу, которая получает на вход строку типа "Иван Иванович Иванов"(ИОФ), а выводит
строку типа "Иванов Иван Иванович"(ФИО)Ответы на вопрос
Отвечает Ахмадуллин Мухаммат.
Ответ:
как то так чтоль
var f,i,o,iof:string;
c,probel:integer;
begin
readln(iof);
probel:=0;
for c:=1 to length(iof) do begin
if (iof[c]<>' ') and (probel=0) then i:=i+iof[c];
if (iof[c]<>' ') and (probel=1) then o:=o+iof[c];
if (iof[c]<>' ') and (probel=2) then f:=f+iof[c];
if iof[c]=' ' then inc(probel);
end;
writeln(f,' ',i,' ',o);
end.
Объяснение:
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Вы можете написать программу на Python, которая преобразует строку типа "Иван Иванович Иванов" в строку типа "Иванов Иван Иванович" следующим образом:
python# Получаем входную строку от пользователя
input_str = input("Введите строку типа ИОФ: ")
# Разбиваем строку на слова
words = input_str.split()
# Проверяем, что введена корректная строка (имеется ровно 3 слова)
if len(words) != 3:
print("Ошибка: Введите строку с ИОФ")
else:
# Формируем ФИО строку в нужном порядке
fio = words[2] + " " + words[0] + " " + words[1]
print("Строка типа ФИО:", fio)
Этот код разбивает введенную строку на слова, проверяет, что в ней есть ровно три слова (Имя, Отчество и Фамилия), а затем формирует строку типа "Фамилия Имя Отчество" и выводит ее на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 37
Информатика 55
Информатика 12
Информатика 266
Информатика 25
Информатика 33
Информатика 16
Информатика 10
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
