Вопрос задан 06.10.2023 в 21:32.
Предмет Информатика.
Спрашивает Ярыза Таня.
Помогите пожалуйста составить программу строго по С++!!!!! Условие1)Дан порядковый номер дня года
(отсчет идет с 1-го января). Выведите номер дня недели этого дня, если 1 января — вторник.Формат входных данныхВводится номер дня года — целое число k (1≤≤365).Формат выходных данныхТребуется вывести номер дня недели для данного дня года (понедельник — 1, вторник — 2, ..., воскресенье — 7).2)Мэрия города М-ска приняла решение провести реновацию домов на улице Льва Толстого. Как известно, дома на этой улице нумеруются натуральными числами от 1 до N, при этом на одной части улицы стоят дома с чётными номерами, а на другой — с нечётными. Кроме этого, дома с номерами от L до R относятся к исторической застройке, и под программу реновации не попадают.Помогите мэрии определить, сколько домов попадет под программу реновации на чётной стороне улицы. Формат входных данныхНа вход программе даются три целых числа N, L и R (1 ≤ L ≤ R ≤ N ≤ 1018).Формат выходных данныхТребуется вывести одно целое число — количество домов, которые попадут под программу реновации на чётной стороне улицы.ПримечанияВ первом примере из условия на чётной стороне улицы 5 домов — 2, 4, 6, 8 и 10. Из них дома 4 и 6 относятся к исторической застройке, поэтому под программу реновации не попадут. Оставшиеся три дома имеют номера 2, 8, 10.Во втором примере, вся чётная сторона улицы относится к исторической застройке.Ответы на вопрос
Отвечает Голдобин Илья.
Ответ:
Вот первая задача
Объяснение:
#include <stdio.h>
int main()
{
int k;
printf("Введите номер дня\n");
scanf("%i", &k);
if((k < 1)||(k > 365))
{
printf("День не подходит");
return 0; // немедленный выход из функции и приложения
}
int den = k % 7; //операция остаток от деления. Тут будет номер дня недели от 0 до 6
den = den + 1 + 2; // 2 - это номер первого дня года, вторника, 1 - это чтобы преобразовать из диапазона 0-6 в диапазон 1-7
printf("День номер %i был %i днем недели", k, den);
return 0;
}

Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программы на C++ для решения обоих задач:
- Номер дня недели для заданного номера дня года:
cpp#include <iostream>
int main() {
int k;
std::cin >> k;
// Номер дня недели для 1 января (вторник)
int dayOfWeek = 2;
// Вычисляем номер дня недели для заданного дня года
dayOfWeek = (dayOfWeek + k - 1) % 7 + 1;
std::cout << dayOfWeek << std::endl;
return 0;
}
- Количество домов под программой реновации на четной стороне улицы:
cpp#include <iostream>
int main() {
long long N, L, R;
std::cin >> N >> L >> R;
// Рассчитываем количество домов на четной стороне улицы
long long evenHouses = N / 2;
// Рассчитываем количество домов на четной стороне улицы, которые не подпадают под программу реновации
long long historicHouses = (R / 2) - ((L - 1) / 2);
// Рассчитываем количество домов, которые попадут под программу реновации на четной стороне улицы
long long renovationHouses = evenHouses - historicHouses;
std::cout << renovationHouses << std::endl;
return 0;
}
Вы можете скомпилировать и выполнить эти программы, вводя значения с клавиатуры, чтобы получить результаты для заданных условий.
Похожие вопросы
Информатика 11
Информатика 34
Информатика 59
Информатика 51
Информатика 76
Информатика 93
Информатика 52
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
