Вопрос задан 06.10.2023 в 16:53.
Предмет Информатика.
Спрашивает Франт Діана.
С++ Написать программу С клавиатуры вводятся n чисел. Составьте программу, которая определяет
количество отрицательных, кол-во положительных и количество нулей среди введённых чисел. Значение n вводится с клавиатурыОтветы на вопрос
Отвечает Иванов Трофим.
#include <iostream>
using namespace std;
int main()
{
int n,x,k_otr=0,k_pol=0,k_nul=0;
cin>>n;
for(int i=1;i<=n;i++)
{
cin>>x;
if(x>0)
k_pol++;
else if(x<0)
k_otr++;
else
k_nul++;
}
cout<<"k_pol="<<k_pol<<"; k_otr="<<k_otr<<"; k_nul="<<k_nul;
return 0;
}
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Для решения этой задачи вам потребуется написать программу на языке C++. Вот пример такой программы:
cpp#include <iostream>
using namespace std;
int main() {
int n;
cout << "Введите количество чисел: ";
cin >> n;
int positiveCount = 0;
int negativeCount = 0;
int zeroCount = 0;
for (int i = 0; i < n; i++) {
int num;
cout << "Введите число #" << (i + 1) << ": ";
cin >> num;
if (num > 0) {
positiveCount++;
} else if (num < 0) {
negativeCount++;
} else {
zeroCount++;
}
}
cout << "Количество положительных чисел: " << positiveCount << endl;
cout << "Количество отрицательных чисел: " << negativeCount << endl;
cout << "Количество нулей: " << zeroCount << endl;
return 0;
}
Эта программа сначала запрашивает у пользователя количество чисел n, затем вводит n чисел и подсчитывает количество положительных, отрицательных и нулевых чисел среди введенных значений. Результаты выводятся на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 75
Информатика 37
Информатика 11
Информатика 41
Информатика 22
Информатика 268
Информатика 36
Информатика 30
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
