Вопрос задан 06.10.2023 в 15:44.
Предмет Информатика.
Спрашивает Чёрный Иван.
Помогите по информатике. Составить программу вычисления (в программе Паскаль) Задачи: 1) Запросить
два числа,вычислить сумму квадратов этих чисел,результат вывести на экран. 2) Составить программу нахождения массы х литров молока,если плотность молока равна 1030 кг/м^3.Ответы на вопрос
Отвечает Чёрный Саша.
:::::::::::::::::::::::::::::::::::::::::::;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
program abc2;
var x,y:real;
begin
x:=0.1;
repeat
if (sqr(x)-1.8*x+1.2)=0 then
writeln('x=',x,'нельзя вычислить функцию')
else
y:=(364*sqr(x)*exp(-7.5*x))/(sqr(x)-1.8*x+1.2);
if y>1 then
writeln('y=',y:8:3);
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программы на языке Pascal для решения ваших задач:
- Программа для вычисления суммы квадратов двух чисел:
pascalprogram SumOfSquares; var num1, num2, sumOfSquares: real; begin writeln('Введите первое число: '); readln(num1); writeln('Введите второе число: '); readln(num2); sumOfSquares := num1 * num1 + num2 * num2; writeln('Сумма квадратов чисел: ', sumOfSquares); end.
- Программа для вычисления массы молока:
pascalprogram MilkMass; var volume, density, mass: real; begin writeln('Введите объем молока (в литрах): '); readln(volume); density := 1030; // Плотность молока в кг/м^3 mass := volume * density; writeln('Масса молока: ', mass:0:2, ' кг'); end.
Эти программы сначала запрашивают необходимые входные данные, затем выполняют вычисления и выводят результат на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Информатика 35
Информатика 54
Информатика 12
Информатика 263
Информатика 25
Информатика 33
Информатика 16
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
