Вопрос задан 05.10.2023 в 23:34. Предмет Информатика. Спрашивает Червоненко Влада.

Написать программу подсчёта количества чисел, больше 5. Pascal ABC Срочно нужно!

0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Марушкина Анастасия.

Ответ:

begin

 var i:= readinteger('Введите число');

 var sum: integer;

 if i>=5 then

     sum := i-5

   else

     sum := 0;

 sum.Println

end.

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот пример программы на Pascal ABC, которая считает количество чисел больше 5:

pascal
program CountNumbersAboveFive; var num, count: integer; begin count := 0; { Инициализация счетчика } while true do begin write('Введите число (для завершения введите 0): '); readln(num); if num = 0 then break; { Если введено 0, завершаем цикл } if num > 5 then count := count + 1; { Увеличиваем счетчик, если число больше 5 } end; writeln('Количество чисел больше 5: ', count); end.

Эта программа просит пользователя ввести числа. Если введено 0, программа завершает работу и выводит количество введенных чисел, которые были больше 5.

Сохраните этот код в файле с расширением .pas (например, count_numbers.pas) и скомпилируйте его с помощью среды разработки Pascal ABC.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос