Вопрос задан 05.10.2023 в 04:29.
Предмет Информатика.
Спрашивает Нурмолдан Акерке.
Обращаюсь к информатикам! Составить программу в Паскале для обработки одномерного массива из 15
чисел. Значения элементов массива задать с клавиатуры самостоятельно. Найти наименьший элемент массива и его номер. Заранее огромное спасибо!!!Ответы на вопрос
Отвечает Хвисюк Ірина.
Pascal ABC
Код:
var
a: array [1..15] of integer;
i, min: integer;
begin
//заполнение массива
for i := 1 to 15 do
readln(a[i]);
//поиск минимума
min := 1;
for i := 1 to 15 do
if a[min] > a[i] then min := i;
//вывод минимального и его номера
writeln('Минимум: ', a[min], ' Номер: ', min);
end.
Тесты:
Ввод:
4 5 7 8 9 2 1 3 4 5 8 7 6 8 2
Вывод:
Минимум: 1 Номер: 7
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот программа на Pascal, которая выполняет задачу по поиску наименьшего элемента в одномерном массиве из 15 чисел и выводит его значение и номер:
pascalprogram MinElementInArray; const N = 15; // Количество элементов в массиве var arr: array[1..N] of Integer; i, minElement, minElementIndex: Integer; begin // Ввод значений массива с клавиатуры writeln('Введите ', N, ' чисел для массива:'); for i := 1 to N do begin write('Элемент ', i, ': '); readln(arr[i]); end; // Инициализация переменных минимального элемента и его индекса minElement := arr[1]; minElementIndex := 1; // Поиск минимального элемента и его индекса в массиве for i := 2 to N do begin if arr[i] < minElement then begin minElement := arr[i]; minElementIndex := i; end; end; // Вывод результатов writeln('Наименьший элемент массива: ', minElement); writeln('Номер наименьшего элемента в массиве: ', minElementIndex); readln; // Чтобы программа не закрывалась сразу end.
Эта программа сначала запрашивает 15 чисел с клавиатуры и сохраняет их в массиве. Затем она находит наименьший элемент и его индекс в массиве и выводит результаты на экран.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
