 
Вопрос задан 05.10.2023 в 00:51.
Предмет Информатика.
Спрашивает Дудь Андрей.
35 баллов!Паскаль.Написать программу по которой из введённого массива А в массив В копируются
только положительные элементы массива А. 9 класс. 0
        0
         0
        0
    Ответы на вопрос
 
        Отвечает Жұмабек Нұрсат.
                
    // PascalABC.NET
begin
var n := ReadInteger('Сколько элементов в массиве?');
var a := ReadArrReal('Вводи:', n);
var b := a.Where(p -> p > 0).ToArray;
b.Print
end.
 0
                    0
                     0
                    0
                 
            Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
                
    Конечно, вот пример программы на Pascal, которая копирует только положительные элементы из массива А в массив В:
pascalprogram CopyPositiveElements; const N = 10; // Максимальный размер массива var A, B: array[1..N] of integer; i, j: integer; begin // Ввод элементов массива A writeln('Введите элементы массива A:'); for i := 1 to N do readln(A[i]); // Копирование положительных элементов из A в B j := 0; // Индекс для массива B for i := 1 to N do begin if A[i] > 0 then begin j := j + 1; B[j] := A[i]; end; end; // Вывод элементов массива B writeln('Массив B (положительные элементы из A):'); for i := 1 to j do writeln(B[i]); end.
В этой программе мы используем два массива A и B. Сначала пользователь вводит элементы массива A. Затем программа копирует только положительные элементы из A в B. Наконец, программа выводит положительные элементы из B.
Обратите внимание, что в этом примере я предположил, что размер массива равен 10 (N = 10). Если размер вашего массива отличается, замените значение N на соответствующее количество элементов.
 0
                    0
                     0
                    0
                Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
	- 
			Математика 
- 
			Литература 
- 
			Алгебра 
- 
			Русский язык 
- 
			Геометрия 
- 
			Английский язык 
- 
			Химия 
- 
			Физика 
- 
			Биология 
- 
			Другие предметы 
- 
			История 
- 
			Обществознание 
- 
			Окружающий мир 
- 
			География 
- 
			Українська мова 
- 
			Информатика 
- 
			Українська література 
- 
			Қазақ тiлi 
- 
			Экономика 
- 
			Музыка 
- 
			Право 
- 
			Беларуская мова 
- 
			Французский язык 
- 
			Немецкий язык 
- 
			МХК 
- 
			ОБЖ 
- 
			Психология 
- 
			Физкультура и спорт 
- 
			Астрономия 
- 
			Кыргыз тили 
- 
			Оʻzbek tili 
 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			 
			