
Вопрос задан 03.10.2023 в 00:39.
Предмет Информатика.
Спрашивает Шерстнёв Николай.
Помогите составить программу на СИ, пользователь вводит строку, в которой все заглавные символы
которые он введёт будут преобразованы в прописные

Ответы на вопрос

Отвечает Теплова Ксения.
Код программы:
#include <locale>
#include <stdio.h>
int main() {
setlocale(LC_ALL, "Russian");
char str[500];
int i;
printf("Введите строку:\n");
fgets(str, 500, stdin);
for (i = 0; i < strlen(str); i++) {
if (isupper(str[i]))
str[i] = tolower(str[i]);
}
printf("\nПреобразованная строка: %s", str);
return 0;
}



Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.
Конечно, вот простая программа на языке C, которая преобразует все заглавные символы в введенной строке в прописные:
c#include <stdio.h>
#include <string.h>
int main() {
char str[100]; // Массив для хранения введенной строки, можно увеличить размер при необходимости
printf("Введите строку: ");
fgets(str, sizeof(str), stdin); // Считываем строку с клавиатуры
// Проходим по строке и преобразуем заглавные символы в прописные
for (int i = 0; i < strlen(str); i++) {
if (str[i] >= 'A' && str[i] <= 'Z') {
str[i] = str[i] + 32; // Преобразование в прописную букву
}
}
printf("Преобразованная строка: %s", str);
return 0;
}
Программа сначала считывает введенную строку с помощью функции fgets
, а затем проходит по строке и преобразует все заглавные буквы в прописные, используя сравнение ASCII-кодов. Результат выводится на экран.


Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
Предметы
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili