Напишите программу вычисляющую сумму элементов массива (в массиве 23 элемента). Все массивы
заполняются случайным образом. Составить алгоритм решения задачи и написать программный код на языке Паскаль.Ответы на вопрос
Ответ:
1.
program z_1;
var i,s;intger;
a:array [1..50] of integer;
begin
for i:=1 to 50 do
begin
readln(a[i]);
s:=s+a[i];
end;
writeln(s);
end.
2.
program z_2;
var c1,c2,pp:integer;
begin
readln(c1);
readln(c2);
pp:=round((c1*c2)/2);//полупроизведение двух чисел
writeln(pp);
end.
3.
program z_3;
var k,v,s:integer;
begin
readln(k);//Стоимость книги
readln(v);//Внесено денег
if k=v then
writeln('Спасибо!')
else
if k<v then
writeln('Возьмите сдачу : ',v-k)
else
writeln('Недостаточно средств : ',k-v);
end.
Объяснение:
Вот пример программы на языке Паскаль, которая вычисляет сумму элементов массива из 23 случайных чисел:
pascalprogram SumOfArrayElements; const N = 23; // Количество элементов в массиве var arr: array[1..N] of integer; // Объявляем массив i, sum: integer; // Переменные для индекса и суммы begin // Заполняем массив случайными числами randomize; // Инициализация генератора случайных чисел for i := 1 to N do arr[i] := random(100); // Генерация случайного числа от 0 до 99 // Вычисляем сумму элементов массива sum := 0; // Инициализируем сумму нулем for i := 1 to N do sum := sum + arr[i]; // Прибавляем к сумме очередной элемент // Выводим результат writeln('Массив:'); for i := 1 to N do writeln('Элемент ', i, ': ', arr[i]); writeln('Сумма элементов массива: ', sum); end.
В этой программе сначала объявляется массив arr из 23 элементов типа integer. Затем с помощью цикла for массив заполняется случайными числами от 0 до 99. После этого сумма элементов массива вычисляется в цикле и выводится на экран, а также выводятся все элементы массива для наглядности.
Заметьте, что данная программа использует генератор случайных чисел, который инициализируется командой randomize. Это необходимо, чтобы каждый раз при запуске программы генерировались новые случайные числа.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
