Вопрос задан 01.10.2023 в 12:28. Предмет Информатика. Спрашивает Космынин Костя.

Напишите код программы:  Ученик 9-го класса собирал данные о температуре воздуха в

течение 20 дней. Результаты он записал в список a. Нужно составить программу, которая определяет количество дней с температурой воздуха выше 3 градусов.​
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Nesmian Tatyana.

На Паскале:

program prog;

var

   a:array[1..20] of integer = (1,3,2,5,3,2,1,3,5,2,6,3,5,6,2,3,4,5,7,6);

   i,c:integer;

begin

   c:=0;

   for i:=1 to 20 do if a[i]>3 then c:=c+1;

   write('Количество дней с температурой воздуха больше 3 градусов: ', c);

end.

На Питоне:

c = 0

a = [1,3,2,5,3,2,1,3,5,2,6,3,5,6,2,3,4,5,7,6]

for i in a:

   if i > 3: c+=1

print(f'Количество дней с температурой воздуха больше 3 градусов: {c}')

Если нужно вводить температуру с клавиатуры:

На Паскале:

program prog;

var

   a:array[1..20] of integer;

   i,c:integer;

begin

   c:=0;

   for i:=1 to 20 do begin

       write('Введите температуру ', i, '-го дня: '); readln(a[i]);

       if a[i]>3 then c:=c+1;

   end;

   write('Количество дней с температурой воздуха больше 3 градусов: ', c);

end.

На Питоне:

c = 0

a = [int(input(f'Введите температуру {i+1}-го дня: ')) for i in range(20)]

print(a)

for i in a:

   if i > 3: c+=1

print(f'Количество дней с температурой воздуха больше 3 градусов: {c}')

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи можно использовать простой код на Python. Вам потребуется создать список a, который будет содержать температуры воздуха за 20 дней, а затем пройти по этому списку и подсчитать количество дней, когда температура выше 3 градусов. Вот код для этой задачи:

python
# Создаем список с данными о температуре воздуха за 20 дней a = [2, 5, 4, 3, 6, 8, 1, 0, 4, 2, 7, 3, 5, 2, 1, 3, 4, 6, 7, 2] # Инициализируем переменную для подсчета дней с температурой выше 3 градусов count_above_3 = 0 # Проходим по списку и проверяем каждый элемент for temperature in a: if temperature > 3: count_above_3 += 1 # Выводим результат print("Количество дней с температурой выше 3 градусов:", count_above_3)

Просто замените значения в списке a на реальные температуры, которые у вас есть, и этот код подсчитает количество дней с температурой выше 3 градусов.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос