Помогите написать программу в ПАСКАЛЕ АВС пж Дано четырехзначное число. найти: число, полученное
при прочтении его цифр справа налево.Ответы на вопрос
Var
n, k: integer;
begin
readln(n);
k:=0;
while n > 0 do
begin
k:=k*10 + n mod 10;
n:=n div 10;
end;
writeln(k);
end.
Вот пример программы на языке Pascal ABC, которая находит число, полученное при прочтении четырехзначного числа справа налево:
```pascal program ReverseDigits; var number, reversedNumber: integer; digit: integer; begin // Вводим четырехзначное число write('Введите четырехзначное число: '); readln(number);
// Инициализируем переменную для хранения перевернутого числа reversedNumber := 0;
// Переворачиваем число while number > 0 do begin // Получаем последнюю цифру числа digit := number mod 10;
// Добавляем цифру к перевернутому числу reversedNumber := reversedNumber * 10 + digit;
// Удаляем последнюю цифру из числа number := number div 10; end;
// Выводим перевернутое число writeln('Число, полученное при прочтении его цифр справа налево: ', reversedNumber);
// Ожидаем нажатия клавиши перед завершением программы readln; end. ```
Программа запрашивает у пользователя ввод четырехзначного числа. Затем она переворачивает это число, путем извлечения последней цифры и добавления ее к переменной `reversedNumber`. После переворачивания числа, программа выводит результат на экран.
Например, если пользователь введет число 1234, программа выведет число 4321.
Примечание: Для запуска программы на языке Pascal ABC вам понадобится установить среду разработки Pascal ABC, которую можно скачать с официального сайта Pascal ABC.
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
