Вопрос задан 30.09.2023 в 08:50. Предмет Информатика. Спрашивает Высоцкая Юлия.

PYTHON!!!!!! пж срочно С ростом волшебного города увеличилось количество купцов, желающих здесь

торговать. Желающих было настолько много, что решено было выдавать лицензию только тем купцам, денежный оборот которых превышает 1000 сентиннеалей. Ваша задача - выбрать из n торговцев тех, чей оборот превышает тысячу сентиннеалей. И определить сколько в итоге торговцев получили право на торговлю. Формат входных данных Вводится целое число торговцев n (1 <= n <= 50) Вводится n целых чисел k, где k - денежный оборот каждого из них (1<=k<=50000) Формат выходных данных Одно число - количество торговцев, чей оборот превысил 1000 сентиннеалей. входные данные выходные данные 5 1000 2000 3000 2 2 2 3 1000 1000 1000 0
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Васенина Валентина.

Ответ:

cnt = 0

n = int(input('Введите количество торговцев: '))

for i in range(n):

   if int(input(f'Введите оборот {i+1}-го торговца: ')) > 1000: cnt+=1

print('Количество торговцев с оборотом, превышающим 1000 равно',cnt)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для решения этой задачи вы можете использовать следующий код на Python:

python
n = int(input()) # Вводим количество торговцев count = 0 # Инициализируем счетчик торговцев с оборотом более 1000 сентиннеалей for _ in range(n): k = int(input()) # Вводим денежный оборот текущего торговца if k > 1000: count += 1 # Если оборот больше 1000, увеличиваем счетчик print(count) # Выводим количество торговцев, чей оборот превысил 1000 сентиннеалей

Этот код сначала получает количество торговцев n, затем вводит оборот каждого торговца и, если оборот превышает 1000 сентиннеалей, увеличивает счетчик count. В конце код выводит количество торговцев, у которых оборот превысил 1000 сентиннеалей.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос