Вопрос задан 29.09.2023 в 22:10. Предмет Информатика. Спрашивает Шелевиля Стас.

Напишите программу на питоне пожалуйста Посчитать сумму чисел, кратных трем (кол-во вводимых

чисел неизвестно, <2^10)
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Соколов Андрей.

a = []

sum = 0

cnt = 0

for i in input().split():

   a.append(int(i))

   cnt = cnt + 1

for i in range(cnt):

   if(a[i] % 3 == 0):

       sum = sum + a[i]

print(sum)

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Конечно, вот программа на Python, которая считает сумму чисел, кратных трём, до тех пор, пока пользователь вводит числа:

python
# Инициализируем переменную для хранения суммы сумма = 0 # Бесконечный цикл для ввода чисел while True: # Вводим число с клавиатуры число = input("Введите число (для выхода введите 'q'): ") # Проверяем, является ли введенная строка 'q' для выхода if число.lower() == 'q': break # Преобразуем введенную строку в целое число число = int(число) # Проверяем, кратно ли число трём if число % 3 == 0: сумма += число # Выводим результат print(f"Сумма чисел, кратных трём: {сумма}")

Эта программа запрашивает числа у пользователя до тех пор, пока пользователь не введет 'q' для выхода, и суммирует числа, кратные трём. После выхода из цикла программа выводит сумму на экран.

0 0

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос