2. Составить программу определения вида треугольника: равносторонний, равнобедренный,
разносторонний.(С++) Ответы на вопрос
Ответ: на с++
Объяснение: как я понял вводится три длины треугольника
#include <iostream>
using namespace std;
int main(){
int a,b,c;
cin >> a >> b >> c;
if(a == b || b == c || a == c){
if(a == b && b == c){
cout << "ravnostoronnyi ";
}
else{
cout << "ravnobedrennyi ";
}
}
else if(a != b && b != c && a != c){
cout << "raznostoronnyi ";
}
return 0;
}
Для определения вида треугольника (равносторонний, равнобедренный, разносторонний) вам нужно будет ввести длины трех его сторон и выполнить проверки. Вот пример программы на C++, которая выполняет эту задачу:
cpp#include <iostream>
using namespace std;
int main() {
double a, b, c;
// Ввод длин сторон треугольника
cout << "Введите длину первой стороны: ";
cin >> a;
cout << "Введите длину второй стороны: ";
cin >> b;
cout << "Введите длину третьей стороны: ";
cin >> c;
// Проверка на равносторонний треугольник
if (a == b && b == c) {
cout << "Треугольник равносторонний." << endl;
}
// Проверка на равнобедренный треугольник
else if (a == b || a == c || b == c) {
cout << "Треугольник равнобедренный." << endl;
}
// В противном случае это разносторонний треугольник
else {
cout << "Треугольник разносторонний." << endl;
}
return 0;
}
Эта программа запрашивает у пользователя длины трех сторон треугольника и затем проверяет их на равенство, чтобы определить тип треугольника.
Похожие вопросы
Топ вопросов за вчера в категории Информатика
Последние заданные вопросы в категории Информатика
-
Математика
-
Литература
-
Алгебра
-
Русский язык
-
Геометрия
-
Английский язык
-
Химия
-
Физика
-
Биология
-
Другие предметы
-
История
-
Обществознание
-
Окружающий мир
-
География
-
Українська мова
-
Информатика
-
Українська література
-
Қазақ тiлi
-
Экономика
-
Музыка
-
Право
-
Беларуская мова
-
Французский язык
-
Немецкий язык
-
МХК
-
ОБЖ
-
Психология
-
Физкультура и спорт
-
Астрономия
-
Кыргыз тили
-
Оʻzbek tili
