Вопрос задан 28.09.2023 в 09:23. Предмет Информатика. Спрашивает Чеснов Александр.

Списки. Часть 2 • Составить программу, которая будет выводить построчно произвольный рисунок

размером не более 60 символов с помощью массива. (Сгенерировать рисунок с помощью онлайн-сервиса, который переводит картинки в ASCII-код). • В программе можно предусмотреть задержку по времени time. sleep (.3) с помощью модуля time . • *(на 12 балов) предусмотреть выбор картинки из нескольких (2-3) с помощью условного оператора if-elif-else.
0 0
Перейти к ответам

Ответы на вопрос

Внимание! Ответы на вопросы дают живые люди. Они могут содержать ошибочную информацию, заблуждения, а также ответы могут быть сгенерированы нейросетями. Будьте внимательны. Если вы уверены, что ответ неверный, нажмите кнопку "Пожаловаться" под ответом.
Отвечает Рудакова Лиза.

Відповідь:

1)

t=[" _________",

"|^|     | |",

"| |_____| |",

"|  _____  |",

'| |     | |',

'| |_____| |',

'|_|_____|_|']

for i in t:

   print(i)

2)

import time

t=[" _________",

"|^|     | |",

"| |_____| |",

"|  _____  |",

'| |     | |',

'| |_____| |',

'|_|_____|_|']

for i in t:

   print(i)

   time.sleep(.3)

 3)

import time

def vivod(a):

   for i in a:

       print(i)

f=2

t1=[" _________",

"|^|     | |",

"| |_____| |",

"|  _____  |",

'| |     | |',

'| |_____| |',

'|_|_____|_|']

t2=[" ________",

"| |____| |",

"|   __   |",

"|  (__)  |",

"|        |",

"|________|"]

t3=[" ______",

"| |__| |",

"|  ()  |",

"|______|"]

while True:

   try:

       f=int(input("Выберите рисунок цифрами 1-3 или 0 для выхода:"))

       if f==1:

           vivod(t1)

       elif f==2:

           vivod(t2)

       elif f==3:

           vivod(t3)

       elif f==0:

           break

   except ValueError:

       print("Неверный ввод")

Пояснення:

0 0
Отвечает нейросеть ChatGpt. Будьте внимательны, ответы нейросети могут содержать ошибочные или выдуманные данные.

Для создания программы, которая выводит произвольный рисунок размером не более 60 символов с использованием массива и предусматривает выбор картинки из нескольких с помощью условных операторов, вы можете использовать следующий код на языке Python:

python
import time # Определение функций для разных рисунков def draw_picture_1(): return [ "**************", "* Picture 1 *", "**************" ] def draw_picture_2(): return [ "**************", "* Picture 2 *", "**************" ] def draw_picture_3(): return [ "**************", "* Picture 3 *", "**************" ] # Выбор рисунка в зависимости от ввода пользователя print("Выберите номер рисунка (1, 2 или 3):") choice = input() if choice == '1': draw_function = draw_picture_1 elif choice == '2': draw_function = draw_picture_2 elif choice == '3': draw_function = draw_picture_3 else: print("Некорректный выбор. Выбран рисунок 1 по умолчанию.") draw_function = draw_picture_1 # Вывод рисунка с задержкой for line in draw_function(): print(line) time.sleep(0.3)

В этом коде мы создали три функции (draw_picture_1, draw_picture_2, draw_picture_3), каждая из которых возвращает рисунок в виде списка строк. Затем мы предлагаем пользователю выбрать номер рисунка с помощью условного оператора if-elif-else. Если выбор пользователя некорректен, то используется рисунок 1 по умолчанию. После выбора рисунка мы выводим его построчно с задержкой в 0.3 секунды между строками.

0 0

Похожие вопросы

Топ вопросов за вчера в категории Информатика

Последние заданные вопросы в категории Информатика

Задать вопрос